summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Zíma <vlastimil.zima@nic.cz>2018-07-19 16:25:20 +0200
committerVlastimil Zíma <vlastimil.zima@nic.cz>2018-07-19 16:25:20 +0200
commit7e8513f4ba1e3fe1eca10564b736ab80f20c1914 (patch)
treee410ec91ef77abe6ef5e025ca69e653284153403
parent0358d9eda92ab82c0b6f6d0e15d5268cc307b6ad (diff)
parent814feb3b7d4fa6b95dfd136806649df25f53dd49 (diff)
downloadopenid-7e8513f4ba1e3fe1eca10564b736ab80f20c1914.tar.gz
Merge branch 'update-quality'
-rw-r--r--.flake85
-rw-r--r--.isort.cfg6
-rw-r--r--Makefile15
-rw-r--r--setup.cfg13
-rw-r--r--tox.ini4
5 files changed, 19 insertions, 24 deletions
diff --git a/.flake8 b/.flake8
deleted file mode 100644
index 843eae4..0000000
--- a/.flake8
+++ /dev/null
@@ -1,5 +0,0 @@
-[flake8]
-max-line-length = 120
-# Ignore E123 - enforce hang-closing instead
-ignore = E123,W503
-max-complexity = 24
diff --git a/.isort.cfg b/.isort.cfg
deleted file mode 100644
index 4d1707b..0000000
--- a/.isort.cfg
+++ /dev/null
@@ -1,6 +0,0 @@
-[settings]
-line_length = 120
-combine_as_imports = true
-default_section = THIRDPARTY
-known_first_party = openid
-add_imports = from __future__ import unicode_literals
diff --git a/Makefile b/Makefile
index c1d31b0..c97b35a 100644
--- a/Makefile
+++ b/Makefile
@@ -1,9 +1,10 @@
-.PHONY: test test-openid test-djopenid coverage isort check-all check-isort check-flake8
+.PHONY: all test test-openid test-djopenid coverage isort
SOURCES = openid setup.py admin contrib
-# Run tests by default
-all: test
+# Run tox by default
+all:
+ tox
test-openid:
python -m unittest discover --start=openid
@@ -22,11 +23,3 @@ coverage:
isort:
isort --recursive ${SOURCES}
-
-check-all: check-isort check-flake8
-
-check-isort:
- isort --check-only --diff --recursive ${SOURCES}
-
-check-flake8:
- flake8 --format=pylint ${SOURCES}
diff --git a/setup.cfg b/setup.cfg
index 5706708..466c48c 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,3 +1,16 @@
+[isort]
+line_length = 120
+combine_as_imports = true
+default_section = THIRDPARTY
+known_first_party = openid
+add_imports = from __future__ import unicode_literals
+
+[flake8]
+max-line-length = 120
+# Ignore E123 - enforce hang-closing instead
+ignore = E123,W503
+max-complexity = 24
+
[sdist]
force_manifest=1
formats=gztar,zip
diff --git a/tox.ini b/tox.ini
index 9e6a894..2be8cff 100644
--- a/tox.ini
+++ b/tox.ini
@@ -28,9 +28,9 @@ commands =
djopenid: coverage run --parallel-mode --branch --source=openid,examples --module unittest discover --start={toxinidir}/examples
[testenv:quality]
-whitelist_externals = make
basepython = python2.7
extras =
quality
commands =
- make check-all
+ isort --check-only --diff --recursive openid setup.py admin contrib
+ flake8 --format=pylint openid setup.py admin contrib