summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Zíma <vlastimil.zima@nic.cz>2020-07-08 11:09:53 +0200
committerVlastimil Zíma <vlastimil.zima@nic.cz>2020-07-14 11:18:25 +0200
commit80cab9c5de068aaa46f9a6fa366545562a5ea267 (patch)
tree485ac263ea0d11ba8243a38970d76883f2239b9e
parent0084ed390362b1b0a9fd6829f279147b0d797b2b (diff)
downloadopenid-80cab9c5de068aaa46f9a6fa366545562a5ea267.tar.gz
Add support for python 3.8
-rw-r--r--.travis.yml1
-rw-r--r--setup.py1
-rw-r--r--tox.ini6
3 files changed, 5 insertions, 3 deletions
diff --git a/.travis.yml b/.travis.yml
index f2f2c46..3db2d3d 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -9,6 +9,7 @@ python:
- "3.5"
- "3.6"
- "3.7"
+ - "3.8"
- "pypy"
addons:
diff --git a/setup.py b/setup.py
index d0ad769..f8f34c4 100644
--- a/setup.py
+++ b/setup.py
@@ -39,6 +39,7 @@ CLASSIFIERS = [
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
'Topic :: Internet :: WWW/HTTP',
'Topic :: Internet :: WWW/HTTP :: Dynamic Content :: CGI Tools/Libraries',
'Topic :: Software Development :: Libraries :: Python Modules',
diff --git a/tox.ini b/tox.ini
index 28abe1d..bd300ca 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,13 +1,13 @@
[tox]
envlist =
quality
- py{27,35,36,37}-{openid,djopenid,httplib2,pycurl,requests}
+ py{27,35,36,37,38}-{openid,djopenid,httplib2,pycurl,requests}
pypy-{openid,djopenid,httplib2,pycurl,requests}
# tox-travis specials
[travis]
python =
- 3.7: py37, quality
+ 3.8: py38, quality
# Generic specification for all unspecific environments
[testenv]
@@ -28,7 +28,7 @@ commands =
djopenid: coverage run --parallel-mode --branch --source=openid,examples --module unittest discover --start={toxinidir}/examples
[testenv:quality]
-basepython = python3.7
+basepython = python3.8
extras =
quality
commands =