summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Zíma <vlastimil.zima@nic.cz>2018-04-30 13:54:44 +0200
committerVlastimil Zíma <vlastimil.zima@nic.cz>2018-04-30 14:04:08 +0200
commita1f08f9fd0cba5c7c97bdc592ca3c69919841012 (patch)
tree033d89a370365de448c32e216b35def58a311bf4
parentee7a9c5c0bbe8b2100b029c151af3cd3e5fd8944 (diff)
downloadopenid-a1f08f9fd0cba5c7c97bdc592ca3c69919841012.tar.gz
Update descriptions
-rw-r--r--MANIFEST.in8
-rw-r--r--README.md11
-rw-r--r--setup.py10
3 files changed, 14 insertions, 15 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index a1d314b..efa752e 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1,7 +1 @@
-include LICENSE NOTICE CHANGELOG MANIFEST.in NEWS background-associations.txt
-graft admin
-graft contrib
-recursive-include examples README discover *.py *.html *.xml
-recursive-include openid/test *.txt dhpriv n2b64 *.py
-recursive-include openid/test/data *
-recursive-include doc *.css *.html
+include *.md
diff --git a/README.md b/README.md
index 2770f60..bce1d2d 100644
--- a/README.md
+++ b/README.md
@@ -5,7 +5,14 @@
[![PyPI](https://img.shields.io/pypi/v/python-openid2.svg)](https://pypi.org/pypi/python-openid2/)
[![PyPI - Python Version](https://img.shields.io/pypi/pyversions/python-openid2.svg)](https://pypi.org/pypi/python-openid2/)
-This is the Python OpenID library.
+Python OpenID library - OpenID support for servers and consumers.
+
+This is a set of Python packages to support use of the OpenID decentralized identity system in your application.
+Want to enable single sign-on for your web site?
+Use the `openid.consumer package`.
+Want to run your own OpenID server?
+Check out `openid.server`.
+Includes example code and support for a variety of storage back-ends.
## REQUIREMENTS ##
@@ -17,7 +24,7 @@ This is the Python OpenID library.
To install the base library, just run the following command:
-pip install python-openid2
+ pip install python-openid2
## GETTING STARTED ##
diff --git a/setup.py b/setup.py
index 89270f9..3e8fdaa 100644
--- a/setup.py
+++ b/setup.py
@@ -23,6 +23,7 @@ EXTRAS_REQUIRE = {
# Dependencies for Django example
'djopenid': ('django<1.11.99', ),
}
+LONG_DESCRIPTION = open('README.md').read() + '\n\n' + open('Changelog.md').read()
CLASSIFIERS = [
'Development Status :: 5 - Production/Stable',
'Environment :: Web Environment',
@@ -42,12 +43,9 @@ CLASSIFIERS = [
setup(
name='python-openid2',
version=VERSION,
- description='OpenID support for servers and consumers.',
- long_description='''This is a set of Python packages to support use of
-the OpenID decentralized identity system in your application. Want to enable
-single sign-on for your web site? Use the openid.consumer package. Want to
-run your own OpenID server? Check out openid.server. Includes example code
-and support for a variety of storage back-ends.''',
+ description='Python OpenID library - OpenID support for servers and consumers.',
+ long_description=LONG_DESCRIPTION,
+ long_description_content_type='text/markdown',
url='https://github.com/ziima/python-openid',
packages=['openid',
'openid.consumer',