summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Zíma <vlastimil.zima@nic.cz>2019-06-17 10:31:46 +0200
committerVlastimil Zíma <vlastimil.zima@nic.cz>2019-06-17 13:38:26 +0200
commitcbd51c1904927e2a3f03cc4c921390d681f0aff8 (patch)
tree5f745e409aaa49c9b2db5cf098e70b81daf38d08
parent68e07736e8ad2122e232258f9d0f067f6f74796a (diff)
downloadopenid-cbd51c1904927e2a3f03cc4c921390d681f0aff8.tar.gz
Add support for python 3.7
-rw-r--r--.travis.yml3
-rw-r--r--setup.py1
-rw-r--r--tox.ini6
3 files changed, 7 insertions, 3 deletions
diff --git a/.travis.yml b/.travis.yml
index 091d075..e8be119 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,4 +1,6 @@
language: python
+# Enable python 3.7
+dist: xenial
sudo: false
@@ -7,6 +9,7 @@ python:
- "3.4"
- "3.5"
- "3.6"
+ - "3.7"
- "pypy"
addons:
diff --git a/setup.py b/setup.py
index 621c4c8..f368c49 100644
--- a/setup.py
+++ b/setup.py
@@ -39,6 +39,7 @@ CLASSIFIERS = [
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
'Topic :: Internet :: WWW/HTTP',
'Topic :: Internet :: WWW/HTTP :: Dynamic Content :: CGI Tools/Libraries',
'Topic :: Software Development :: Libraries :: Python Modules',
diff --git a/tox.ini b/tox.ini
index c548f3f..bbcdc0b 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,13 +1,13 @@
[tox]
envlist =
quality
- py{27,34,35,36}-{openid,djopenid,httplib2,pycurl,requests}
+ py{27,34,35,36,37}-{openid,djopenid,httplib2,pycurl,requests}
pypy-{openid,djopenid,httplib2,pycurl,requests}
# tox-travis specials
[travis]
python =
- 2.7: py27, quality
+ 3.7: py37, quality
# Generic specification for all unspecific environments
[testenv]
@@ -28,7 +28,7 @@ commands =
djopenid: coverage run --parallel-mode --branch --source=openid,examples --module unittest discover --start={toxinidir}/examples
[testenv:quality]
-basepython = python2.7
+basepython = python3.7
extras =
quality
commands =