summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorVlastimil Zíma <vlastimil.zima@nic.cz>2017-11-24 15:07:29 +0100
committerVlastimil Zíma <vlastimil.zima@nic.cz>2017-11-29 08:38:30 +0100
commit8f0ff0d27771514d16a415b8ac76d18ea0809f38 (patch)
tree06b56cd9666f85aec459e9264e4c724f86c70f0d /Makefile
parentf58d7cee3e9f4bff9854dc10ffcd105fb3bc6619 (diff)
downloadopenid-8f0ff0d27771514d16a415b8ac76d18ea0809f38.tar.gz
Pepify and add flake8
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 8b77909..2cba277 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,4 @@
-.PHONY: test coverage isort check-isort
+.PHONY: test coverage isort check-all check-isort check-flake8
test:
python admin/runtests
@@ -12,5 +12,10 @@ coverage:
isort:
isort --recursive .
+check-all: check-isort check-flake8
+
check-isort:
isort --check-only --diff --recursive .
+
+check-flake8:
+ flake8 --format=pylint .