summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorVlastimil Zíma <vlastimil.zima@nic.cz>2018-01-26 16:17:41 +0100
committerVlastimil Zíma <vlastimil.zima@nic.cz>2018-03-07 15:06:24 +0100
commitff6b54f3b66bcad8e3e9beaab9a7e6ab492fbf2a (patch)
treeb6e53d54986aa441d0c91c38ef66500d3ff41e69 /setup.py
parent6006ed0594ed4b120ae7999d75d4594f65fc1f1c (diff)
downloadopenid-ff6b54f3b66bcad8e3e9beaab9a7e6ab492fbf2a.tar.gz
Use lxml for XML
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 5 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 4b7e934..876da4f 100644
--- a/setup.py
+++ b/setup.py
@@ -7,6 +7,10 @@ if 'sdist' in sys.argv:
os.system('./admin/makedoc')
version = '[library version:2.2.5]'[17:-1]
+INSTALL_REQUIRES = [
+ 'lxml;platform_python_implementation=="CPython"',
+ 'lxml <4.0;platform_python_implementation=="PyPy"',
+]
EXTRAS_REQUIRE = {
'quality': ('flake8', 'isort'),
'tests': ('mock', 'testfixtures'),
@@ -35,6 +39,7 @@ and support for a variety of storage back-ends.''',
'openid.extensions',
'openid.extensions.draft',
],
+ install_requires=INSTALL_REQUIRES,
extras_require=EXTRAS_REQUIRE,
# license specified by classifier.
# license=getLicense(),