summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitattributes1
-rw-r--r--.gitignore2
-rw-r--r--Makefile10
3 files changed, 13 insertions, 0 deletions
diff --git a/.gitattributes b/.gitattributes
new file mode 100644
index 0000000..1aadc14
--- /dev/null
+++ b/.gitattributes
@@ -0,0 +1 @@
+/Makefile whitespace=space-before-tab,indent-with-non-tab,tabwidth=4
diff --git a/.gitignore b/.gitignore
index f1ff221..faa1bf6 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,4 +3,6 @@
*.swp
.tox
# Created in tests
+/.coverage
+/htmlcov
/sstore
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..161b421
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,10 @@
+.PHONY: test coverage
+
+test:
+ python admin/runtests
+
+coverage:
+ python-coverage erase
+ -rm -r htmlcov
+ python-coverage run --branch --source="." admin/runtests
+ python-coverage html --directory=htmlcov