summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 2a2b1a4..7053456 100644
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,7 @@
.PHONY: test coverage isort check-all check-isort check-flake8
+SOURCES = openid setup.py admin contrib
+
test:
PYTHONPATH="examples" DJANGO_SETTINGS_MODULE="djopenid.settings" python -m unittest discover
@@ -10,12 +12,12 @@ coverage:
python -m coverage html --directory=htmlcov
isort:
- isort --recursive .
+ isort --recursive ${SOURCES}
check-all: check-isort check-flake8
check-isort:
- isort --check-only --diff --recursive .
+ isort --check-only --diff --recursive ${SOURCES}
check-flake8:
- flake8 --format=pylint .
+ flake8 --format=pylint ${SOURCES}