summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini16
1 files changed, 14 insertions, 2 deletions
diff --git a/tox.ini b/tox.ini
index aee1fcc..7baedc7 100644
--- a/tox.ini
+++ b/tox.ini
@@ -63,8 +63,20 @@ show-source = true
builtins = _
exclude=.venv,.git,.tox,dist,doc,*lib/python*,*egg,tools,setup.py,build,releasenotes
-[hacking]
-local-check-factory = osprofiler.hacking.checks.factory
+[flake8:local-plugins]
+extension =
+ N301 = checks:check_assert_methods_from_mock
+ N320 = checks:assert_true_instance
+ N321 = checks:assert_equal_type
+ N322 = checks:assert_equal_none
+ N323 = checks:assert_true_or_false_with_in
+ N324 = checks:assert_equal_in
+ N350 = checks:check_quotes
+ N351 = checks:check_no_constructor_data_struct
+ N352 = checks:check_dict_formatting_in_string
+ N353 = checks:check_using_unicode
+ N354 = checks:check_raises
+paths = ./osprofiler/hacking
[testenv:releasenotes]
commands = sphinx-build -a -E -W -d releasenotes/build/doctrees -b html releasenotes/source releasenotes/build/html