summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Collins <elic@assurancetechnologies.com>2020-10-06 13:46:32 -0400
committerEli Collins <elic@assurancetechnologies.com>2020-10-06 13:46:32 -0400
commit05c5cbc9a664b98449566f16f832a8e2d392e1dd (patch)
treecb545453071dbbdfbd03862308eb8a454c8bf020
parentdb09b6032eadf839844e2275c163d33f744bf255 (diff)
downloadpasslib-05c5cbc9a664b98449566f16f832a8e2d392e1dd.tar.gz
docs & setup: updates text & setup requirements to indicate we need minimum
of Python 3.5.
-rw-r--r--README2
-rw-r--r--docs/history/1.8.rst9
-rw-r--r--docs/history/index.rst10
-rw-r--r--docs/index.rst2
-rw-r--r--docs/install.rst17
-rw-r--r--docs/lib/passlib.context.rst6
-rw-r--r--passlib/utils/compat/__init__.py4
-rw-r--r--setup.py10
8 files changed, 28 insertions, 32 deletions
diff --git a/README b/README
index abd701f..1c2d54c 100644
--- a/README
+++ b/README
@@ -6,7 +6,7 @@ The Passlib Python Library
Welcome
=======
-Passlib is a password hashing library for Python 2 & 3, which provides
+Passlib is a password hashing library for Python 3, which provides
cross-platform implementations of over 30 password hashing algorithms, as well
as a framework for managing existing password hashes. It's designed to be useful
for a wide range of tasks, from verifying a hash found in /etc/shadow, to
diff --git a/docs/history/1.8.rst b/docs/history/1.8.rst
index 67e54b8..f13a130 100644
--- a/docs/history/1.8.rst
+++ b/docs/history/1.8.rst
@@ -20,8 +20,17 @@ Overview
See https://passlib.readthedocs.io/en/stable/history/1.7.html for the latest release.
+Requirements
+------------
+
+* **Passlib now requires Python >= 3.5.** As of this release, support for Python 2.x, 3.3,
+ and 3.4 has been dropped. If you need to use Passlib on an earlier version of Python,
+ please use the :doc:`1.7` series, which will be maintained in bugfix-only mode
+ for few more releases. (See :issue:`119` for rationale).
+
Backwards Incompatibilities
---------------------------
+
The following previously-deprecated features were removed,
though few of these should be in use, as they've been deprecated
for a number of years / releases:
diff --git a/docs/history/index.rst b/docs/history/index.rst
index 8439c5e..938f860 100644
--- a/docs/history/index.rst
+++ b/docs/history/index.rst
@@ -10,19 +10,13 @@ Release History
**For the latest release:** see :ref:`What's New <whats-new>` in Passlib 1.8
+.. rst-class:: float-center without-title
+
.. toctree::
:maxdepth: 2
1.8 Series <1.8>
-.. rst-class:: float-center without-title
-
-.. warning::
-
- **Passlib 1.8 will drop support for Python 2.x, 3.3, and 3.4**;
- and will require Python >= 3.5. The 1.7 series will be the last
- to support Python 2.7. (See :issue:`119` for rationale).
-
.. toctree::
:maxdepth: 2
diff --git a/docs/index.rst b/docs/index.rst
index 4452c63..20f0604 100644
--- a/docs/index.rst
+++ b/docs/index.rst
@@ -33,7 +33,7 @@ Passlib |release| documentation
Welcome
=======
-Passlib is a password hashing library for Python 2 & 3, which provides
+Passlib is a password hashing library for Python 3, which provides
cross-platform implementations of over 30 password hashing algorithms, as well
as a framework for managing existing password hashes. It's designed to be useful
for a wide range of tasks, from verifying a hash found in /etc/shadow, to
diff --git a/docs/install.rst b/docs/install.rst
index 2ebe119..af9507a 100644
--- a/docs/install.rst
+++ b/docs/install.rst
@@ -6,27 +6,28 @@ Installation
Supported Platforms
===================
-Passlib requires Python 2 (>= 2.6) or Python 3 (>= 3.3).
+Passlib requires Python 3.5 or newer.
It is known to work with the following Python implementations:
.. rst-class:: float-right without-title
.. warning::
- **Passlib 1.8 will drop support for Python 2.x, 3.3, and 3.4**;
- and will require Python >= 3.5. The 1.7 series will be the
- last to support Python 2. (See :issue:`119` for rationale).
+ **Passlib 1.8 dropped support for Python 2.x, 3.3, and 3.4**;
+ If you need support for Python 2.6 - 3.4, use the Passlib 1.7.x series.
-* CPython 2 -- v2.6 or newer.
-* CPython 3 -- v3.3 or newer.
-* PyPy -- v2.0 or newer.
+* CPython 3 -- v3.5 or newer.
* PyPy3 -- v5.3 or newer.
-* Jython -- v2.7 or newer.
Passlib should work with all operating systems and environments,
as it contains builtin fallbacks for almost all OS-dependant features.
Google App Engine is supported as well.
+.. versionchanged:: 1.8
+
+ Support for Python 2.x, 3.3, and 3.4 was dropped.
+ Jython no longer listed, until it has a Python 3 compatible for testing.
+
.. versionchanged:: 1.7
Support for Python 2.5, 3.0-3.2 was dropped.
diff --git a/docs/lib/passlib.context.rst b/docs/lib/passlib.context.rst
index 10fb2a0..bec6f7e 100644
--- a/docs/lib/passlib.context.rst
+++ b/docs/lib/passlib.context.rst
@@ -507,9 +507,3 @@ if any invalid-but-correctable values are encountered
Other Helpers
=============
.. autoclass:: LazyCryptContext([schemes=None,] \*\*kwds [, onload=None])
-
-.. rst-class:: html-toggle
-
-The CryptPolicy Class (deprecated)
-==================================
-.. autoclass:: CryptPolicy
diff --git a/passlib/utils/compat/__init__.py b/passlib/utils/compat/__init__.py
index 1cd4c8d..b2aaf5b 100644
--- a/passlib/utils/compat/__init__.py
+++ b/passlib/utils/compat/__init__.py
@@ -11,8 +11,8 @@ PY2 = sys.version_info < (3,0)
PY3 = sys.version_info >= (3,0)
# make sure it's not an unsupported version, even if we somehow got this far
-if sys.version_info < (2,6) or (3,0) <= sys.version_info < (3,2):
- raise RuntimeError("Passlib requires Python 2.6, 2.7, or >= 3.2 (as of passlib 1.7)")
+if sys.version_info < (3, 5):
+ raise RuntimeError("Passlib requires Python >= 3.5 (as of passlib 1.8)")
PY26 = sys.version_info < (2,7)
diff --git a/setup.py b/setup.py
index 5310d4f..75c6b8c 100644
--- a/setup.py
+++ b/setup.py
@@ -64,6 +64,9 @@ opts = dict(
],
},
+ # NOTE: 'python_requires' should be kept in sync w/ passlib.utils.compat's version check.
+ python_requires='>=3.5',
+
#==================================================================
# details
#==================================================================
@@ -71,7 +74,7 @@ opts = dict(
"comprehensive password hashing framework supporting over 30 schemes",
long_description="""\
-Passlib is a password hashing library for Python 2 & 3, which provides
+Passlib is a password hashing library for Python 3, which provides
cross-platform implementations of over 30 password hashing algorithms, as well
as a framework for managing existing password hashes. It's designed to be useful
for a wide range of tasks, from verifying a hash found in /etc/shadow, to
@@ -103,12 +106,7 @@ Intended Audience :: Developers
License :: OSI Approved :: BSD License
Natural Language :: English
Operating System :: OS Independent
-Programming Language :: Python :: 2
-Programming Language :: Python :: 2.6
-Programming Language :: Python :: 2.7
Programming Language :: Python :: 3
-Programming Language :: Python :: 3.3
-Programming Language :: Python :: 3.4
Programming Language :: Python :: 3.5
Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7