summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Collins <elic@assurancetechnologies.com>2011-06-29 13:58:17 -0400
committerEli Collins <elic@assurancetechnologies.com>2011-06-29 13:58:17 -0400
commit458ef5897adf5d10bec13acc69da493135c4d9f8 (patch)
treecacf1f2bfe892a084c02835c119782e23c426999
parent62991573b68a5db0815db0f48532ef967380422e (diff)
downloadpasslib-458ef5897adf5d10bec13acc69da493135c4d9f8.tar.gz
changed setup.cfg so nose works properly again; minor tweaks to setup.py
-rw-r--r--setup.cfg2
-rw-r--r--setup.py10
2 files changed, 6 insertions, 6 deletions
diff --git a/setup.cfg b/setup.cfg
index 93a527d..8945f79 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -15,4 +15,4 @@ upload_dir = docs/_build/html
test_suite = nose.collector
[nosetests]
-where = passlib/tests
+tests = passlib/tests
diff --git a/setup.py b/setup.py
index b5b09c0..b41ded9 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,6 @@
"""passlib setup script"""
#=========================================================
-#init script env - ensure cwd = root of source dir
+#init script env -- ensure cwd = root of source dir
#=========================================================
import os
root_dir = os.path.abspath(os.path.join(__file__,".."))
@@ -21,14 +21,16 @@ except ImportError:
has_distribute = False
#=========================================================
-#monkeypatch preprocessor into 2to3, and enable 2to3
+#enable various 2to3 options
#=========================================================
opts = { "cmdclass": {} }
if py3k:
+ #monkeypatch preprocessor into lib2to3
from passlib.setup.cond2to3 import patch2to3
patch2to3()
+ #enable 2to3 translation in build_py
if has_distribute:
opts['use_2to3'] = True
else:
@@ -40,9 +42,7 @@ if py3k:
#=========================================================
#version string
#=========================================================
-vh = open(os.path.join(root_dir, "passlib", "__init__.py"))
-VERSION = re.search(r'^__version__\s*=\s*"(.*?)"\s*$', vh.read(), re.M).group(1)
-vh.close()
+from passlib import __version__ as VERSION
#=========================================================
#static text