summaryrefslogtreecommitdiff
path: root/admin
diff options
context:
space:
mode:
authorEli Collins <elic@assurancetechnologies.com>2015-07-25 14:33:41 -0400
committerEli Collins <elic@assurancetechnologies.com>2015-07-25 14:33:41 -0400
commita16500cdb9cc27c68a4c8f349f5f67a2f4ee355f (patch)
treebf6f07d9e69b02409f1723d74ea1655aea934301 /admin
parentafea4e0e507cca61676911e9f2712703cd135ee4 (diff)
parent80f093c922b64dfaedd00194a2fe16648fe2a8d0 (diff)
downloadpasslib-a16500cdb9cc27c68a4c8f349f5f67a2f4ee355f.tar.gz
Merge from stable
Diffstat (limited to 'admin')
-rwxr-xr-xadmin/upload.sh51
1 files changed, 3 insertions, 48 deletions
diff --git a/admin/upload.sh b/admin/upload.sh
index 4044f1f..d8f6e71 100755
--- a/admin/upload.sh
+++ b/admin/upload.sh
@@ -1,6 +1,6 @@
#!/bin/sh
#
-# helper script to build & upload passlib to pypi & google code
+# helper script to build & upload passlib to pypi
#
SEP1="====================================================="
@@ -10,17 +10,6 @@ SEP2="-----------------------------------------------------"
# init config
#
-if [ -z "$GC_USER" ]; then
- echo "GC_USER not set"
- exit 1
-fi
-
-if [ -z "$GC_PASSWORD" ]; then
- echo "GC_PASSWORD not set"
- exit 1
-fi
-
-GC_CMD="googlecode_upload.py -p passlib -u $GC_USER -w $GC_PASSWORD"
if [ -z "$DRY_RUN" ]; then
echo "DRY_RUN not set"
exit 1
@@ -28,7 +17,6 @@ elif [ "$DRY_RUN" -eq 1 ]; then
echo "dry run"
UPLOAD_ARG=""
UPLOAD_DOCS_ARG=""
- GC_CMD="echo >>> $GC_CMD"
else
echo "real run"
UPLOAD_ARG="upload"
@@ -40,8 +28,6 @@ VTAIL="Release-${VSTR}"
echo "$SEP1"
echo "DRY_RUN=$DRY_RUN"
-echo "GC_USER=$GC_USER"
-echo "GC_PASSWORD=$GC_PASSWORD"
echo "VERSION=$VSTR"
#
@@ -55,43 +41,12 @@ if [ -z "$SKIP_PYPI" ]; then
# upload source
echo "\n$SEP1\nbuilding and uploading source to pypi\n$SEP2"
- python setup.py --for-release sdist $UPLOAD_ARG
+ python setup.py --for-release sdist bdist_wheel $UPLOAD_ARG
# upload docs
echo "\n$SEP1\nbuilding and uploading docs to pypi\n$SEP2"
PASSLIB_DOCS="for-pypi" python setup.py --for-release build_sphinx $UPLOAD_DOCS_ARG
fi
-#
-# upload to google code
-#
-if [ -z "$SKIP_GC" ]; then
-
- # build & sign docdist for google code
- echo "\n$SEP1\nbuilding and signing docs.zip\n$SEP2"
- python setup.py --for-release docdist
- gpg --detach-sign -a dist/passlib-docs*.zip
-
- # move into dist for google code
- cd dist
-
- # upload source to gc
- echo "\n$SEP1\nuploading source to google code\n$SEP2"
- SDIST="passlib-${VSTR}.tar.gz"
- DZIP="passlib-docs-${VSTR}.zip"
- if [ ! -f "$SDIST" -o ! -f "$SDIST.asc" -o ! -f "$DZIP" -o ! -f "$DZIP.asc" ]; then
- echo "error: release file(s) not found"
- exit 1
- fi
- $GC_CMD -l Featured,Type-Source,OpSys-All,$VTAIL -s "Passlib ${VSTR} source distribution" $SDIST
- $GC_CMD -l Type-Signature-Source,$VTAIL -s "Passlib ${VSTR} source distribution - PGP signature" passlib-${VSTR}.tar.gz.asc
-
- echo "\n$SEP1\nuploading docs to google code\n$SEP2"
- $GC_CMD -l Type-Docs,OpSys-All,$VTAIL -s "Passlib ${VSTR} standalone documentation" passlib-docs-${VSTR}.zip
- $GC_CMD -l Type-Signature-Docs,$VTAIL -s "Passlib ${VSTR} standalone documentation - PGP signature" passlib-docs-${VSTR}.zip.asc
-
- # move back again
- cd ..
-fi
-echo "\n$SEP1\ndone." \ No newline at end of file
+echo "\n$SEP1\ndone."