summaryrefslogtreecommitdiff
path: root/docs
diff options
context:
space:
mode:
authorEli Collins <elic@assurancetechnologies.com>2019-11-19 14:41:31 -0500
committerEli Collins <elic@assurancetechnologies.com>2019-11-19 14:41:31 -0500
commitb6b227b144dc638bd8e4fb9c220652da68e00cb8 (patch)
tree6cc07f8e36648834de106d2f687388b295ba3e64 /docs
parentfb5484ca8006a722c21a9bb51e89b21ff8553266 (diff)
downloadpasslib-b6b227b144dc638bd8e4fb9c220652da68e00cb8.tar.gz
docs: minor text & build issues
* fix some typos * silence unrefrenced footnote warnings (expected, can fix later) * add intersphinx config to link to py3 stdlib
Diffstat (limited to 'docs')
-rw-r--r--docs/conf.py8
-rw-r--r--docs/install.rst4
-rw-r--r--docs/lib/passlib.pwd.rst4
3 files changed, 12 insertions, 4 deletions
diff --git a/docs/conf.py b/docs/conf.py
index 2740e94..7b61d34 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -82,6 +82,9 @@ extensions = [
'cloud_sptheme.ext.autoattribute_search_bases',
'cloud_sptheme.ext.docfield_markup',
'cloud_sptheme.ext.escaped_samp_literals',
+
+ # silence "footnote not referenced" warning -- should maybe redo these in docs :)
+ 'cloud_sptheme.ext.allow_unreferenced_footnotes',
]
# Add any paths that contain templates here, relative to this directory.
@@ -159,6 +162,11 @@ modindex_common_prefix = ["passlib."]
# appended to all pages
rst_epilog = "\n.. |updated| replace:: %s\n" % updated
+# Intersphinx
+intersphinx_mapping = {
+ 'python': ('https://docs.python.org/3', None),
+}
+
#=============================================================================
# Options for all output
#=============================================================================
diff --git a/docs/install.rst b/docs/install.rst
index 7af15ff..2f09ea6 100644
--- a/docs/install.rst
+++ b/docs/install.rst
@@ -139,7 +139,7 @@ If you wish to generate your own copy of the documentation,
you will need to:
1. Download the Passlib source, extract it, and ``cd`` into the source directory.
-2. Install all the dependencies required via ``pip install -e .[build_docs]``
+2. Install all the dependencies required via ``pip install -e .[build_docs]``.
3. Run :samp:`python setup.py build_sphinx`.
-5. Once Sphinx completes its run, point a web browser to the file at :samp:`{SOURCE}/build/sphinx/html/index.html`
+4. Once Sphinx completes its run, point a web browser to the file at :samp:`{SOURCE}/build/sphinx/html/index.html`
to access the Passlib documentation in html format.
diff --git a/docs/lib/passlib.pwd.rst b/docs/lib/passlib.pwd.rst
index bb36844..8b41bd8 100644
--- a/docs/lib/passlib.pwd.rst
+++ b/docs/lib/passlib.pwd.rst
@@ -47,6 +47,6 @@ Passlib does not currently offer any password strength estimation routines.
However, the (javascript-based) `zxcvbn <https://github.com/dropbox/zxcvbn>`_
project is a *very* good choice.
-Though there are a few different python ports of ZXCVBN library, as of 2019-3-4,
-`zxcvbn <https://pypi.python.org/pypi/zxcvbn>` is the most up-to-date,
+Though there are a few different python ports of ZXCVBN library, as of 2019-11-13,
+`zxcvbn (@ pypi) <https://pypi.python.org/pypi/zxcvbn>`_ is the most up-to-date,
and is endorsed by the upstream zxcvbn developers.