summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorEli Collins <elic@assurancetechnologies.com>2011-06-01 15:16:33 -0400
committerEli Collins <elic@assurancetechnologies.com>2011-06-01 15:16:33 -0400
commit63e57bb87e3fd60dc28de429f36451681ac1159b (patch)
tree6b81d199d660ef31b22099987f954d8d28935f41 /setup.py
parent0d107f56f554d81262436de7399212cb5d03aa55 (diff)
downloadpasslib-63e57bb87e3fd60dc28de429f36451681ac1159b.tar.gz
setup tweaks: updated long description to include links, added some keywords, download url set to version specific sdist
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 12 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 468cedc..afcbe81 100644
--- a/setup.py
+++ b/setup.py
@@ -5,6 +5,7 @@
import os
root_dir = os.path.abspath(os.path.join(__file__,".."))
os.chdir(root_dir)
+
#=========================================================
#imports
#=========================================================
@@ -29,9 +30,17 @@ implementations of over 20 password hashing algorithms; as well as a framework f
and migrating existing password hashes. It's designed to be useful
for any task from quickly verifying a hash found in /etc/shadow,
to providing full-strength password hashing for multi-user applications.
+
+* See the `online documentation <http://packages.python.org/passlib>`_ for details and examples.
+
+* See the `passlib homepage <http://passlib.googlecode.com>`_ for the latest news, more information, and additional downloads.
+
+* See the `changelog <http://packages.python.org/passlib/history.html>`_ for list of what's new in passlib.
+
+All releases are signed with the gpg key `4CE1ED31 <http://pgp.mit.edu:11371/pks/lookup?op=get&search=0x4D8592DF4CE1ED31>`_.
"""
-KEYWORDS = "password secret hash security crypt md5-crypt sha256-crypt sha512-crypt bcrypt htpasswd htdigest pbkdf2"
+KEYWORDS = "password secret hash security crypt md5-crypt sha256-crypt sha512-crypt bcrypt apache htpasswd htdigest pbkdf2 ntlm"
setup(
#package info
@@ -46,9 +55,8 @@ setup(
author_email = "elic@assurancetechnologies.com",
license = "BSD",
- url = "http://code.google.com/p/passlib/",
- #er, is download url for the sdist, or for the project?
-## download_url = "http://code.google.com/p/passlib/downloads/list",
+ url = "http://passlib.googlecode.com",
+ download_url = "http://passlib.googlecode.com/files/passlib-" + VERSION + ".tar.gz",
description = DESCRIPTION,
long_description = LONG_DESCRIPTION,