summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--docs/history.rst2
-rw-r--r--docs/index.rst8
-rw-r--r--docs/install.rst35
-rw-r--r--passlib.komodoproject20
-rw-r--r--setup.cfg3
-rw-r--r--setup.py8
6 files changed, 43 insertions, 33 deletions
diff --git a/docs/history.rst b/docs/history.rst
index 6cfc820..99f9adb 100644
--- a/docs/history.rst
+++ b/docs/history.rst
@@ -2,7 +2,7 @@
Release History
===============
-**1.3** (To Be Released)
+**1.3** (2011-03-25)
* first public release
* documentation completed
diff --git a/docs/index.rst b/docs/index.rst
index 46cfc34..7a6acce 100644
--- a/docs/index.rst
+++ b/docs/index.rst
@@ -43,3 +43,11 @@ Quick Links
</td>
</tr>
</table>
+
+Online Resources
+================
+* **Homepage**: `<http://code.google.com/p/passlib/>`_.
+* **Downloads**: `<http://code.google.com/p/downloads/>`_.
+* **PyPI**: `<http://pypi.python.org/pypi/passlib/>`_.
+* **Docs**: `<http://packages.python.org/passlib/>`_.
+* **Source**: `<http://code.google.com/p/passlib/source/>`_
diff --git a/docs/install.rst b/docs/install.rst
index 8837e6f..fb99468 100644
--- a/docs/install.rst
+++ b/docs/install.rst
@@ -58,19 +58,22 @@ Once PassLib and Nose have been installed, the tests may be run from the source
# to run all tests...
PASSLIB_TESTS="all" nosetests -v passlib/tests
-Documentation
-=============
-The latest copy of this documentation should always be available
-at the `PassLib homepage <http://www.assurancetechnologies.com/software/passlib>`_.
-
-If you wish to generate your own copy of the documentation,
-you will need to:
-
-* install `Sphinx <http://sphinx.pocoo.org/>`_ (1.0 or better)
-* install `astdoc <http://www.assurancetechnologies.com/software/astdoc>`_ (a bundle of custom sphinx themes & extensions
- used by Assurance Technologies).
-* download the PassLib source
-* run :samp:`python docs/make.py clean html`.
-
-Once Sphinx completes it's run, point a web browser to the file at :samp:`docs/_build/html/index.html`
-to access the PassLib documentation in html format.
+..
+ NOTE: commented this out from published manual, until astdoc package is cleaned up
+
+ Documentation
+ =============
+ The latest copy of this documentation should always be available
+ online at `<http://packages.python.org/passlib>`_.
+
+ If you wish to generate your own copy of the documentation,
+ you will need to:
+
+ * install `Sphinx <http://sphinx.pocoo.org/>`_ (1.0 or better)
+ * install `astdoc <XXX url not available yet XXX>`_ (a bundle of custom sphinx themes & extensions
+ used by Assurance Technologies).
+ * download the PassLib source
+ * run :samp:`python docs/make.py clean html`.
+
+ Once Sphinx completes it's run, point a web browser to the file at :samp:`docs/_build/html/index.html`
+ to access the PassLib documentation in html format.
diff --git a/passlib.komodoproject b/passlib.komodoproject
index 4834038..3f0acfb 100644
--- a/passlib.komodoproject
+++ b/passlib.komodoproject
@@ -1,10 +1,10 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!-- Komodo Project File - DO NOT EDIT -->
-<project id="ab14e891-3bad-4dee-94c1-e8ad8d6ca1a9" kpf_version="5" name="passlib.komodoproject">
-<preference-set idref="ab14e891-3bad-4dee-94c1-e8ad8d6ca1a9">
- <string relative="path" id="import_dirname"></string>
- <string id="import_exclude_matches">cover;_build;dist;build;.*;*.*~;*.bak;*.tmp;CVS;.#*;*.pyo;*.pyc;.svn;*%*;tmp*.html;.DS_Store</string>
- <string id="import_include_matches"></string>
- <boolean id="import_live">1</boolean>
-</preference-set>
-</project>
+<?xml version="1.0" encoding="UTF-8"?>
+<!-- Komodo Project File - DO NOT EDIT -->
+<project id="ab14e891-3bad-4dee-94c1-e8ad8d6ca1a9" kpf_version="5" name="passlib.komodoproject">
+<preference-set idref="ab14e891-3bad-4dee-94c1-e8ad8d6ca1a9">
+ <string relative="path" id="import_dirname"></string>
+ <string id="import_exclude_matches">cover;_build;dist;build;.*;*.*~;*.bak;*.tmp;CVS;.#*;*.pyo;*.pyc;.svn;*%*;tmp*.html;.DS_Store</string>
+ <string id="import_include_matches"></string>
+ <boolean id="import_live">1</boolean>
+</preference-set>
+</project>
diff --git a/setup.cfg b/setup.cfg
index 850f440..3036304 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,3 +1,2 @@
[egg_info]
-tag_build = b1
-
+tag_build = .0
diff --git a/setup.py b/setup.py
index d50a37e..5875147 100644
--- a/setup.py
+++ b/setup.py
@@ -24,10 +24,10 @@ setup(
author_email = "elic@assurancetechnologies.com",
license = "BSD",
- url = "http://www.assurancetechnologies.com/software/passlib",
- #download_url
+ url = "http://code.google.com/p/passlib/",
+ download_url = "http://code.google.com/p/passlib/downloads/list",
- description = "password hash library",
+ description = "password hashing library",
long_description = """\
PassLib is a password hash library, which provides cross-platform
implementations of over 20 password hashing algorithms; as well as a framework for managing
@@ -38,7 +38,7 @@ to providing full-strength password hashing for multi-user application.
keywords = "password secret hash security crypt md5-crypt sha256-crypt sha512-crypt bcrypt htpasswd htdigest",
classifiers = [
- "Development Status :: 4 - Beta",
+ "Development Status :: 5 - Production/Stable",
"Intended Audience :: Developers",
"License :: OSI Approved :: BSD License",
"Natural Language :: English",