summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--README2
-rw-r--r--docs/conf.py5
-rw-r--r--setup.py4
3 files changed, 8 insertions, 3 deletions
diff --git a/README b/README
index 37a8019..c00296d 100644
--- a/README
+++ b/README
@@ -15,7 +15,7 @@ providing full-strength password hashing for multi-user application.
* See the `documentation <https://passlib.readthedocs.io>`_
for details, installation instructions, and examples.
-* See the `changelog <https://passlib.readthedocs.io/en/stable/history.html>`_
+* See the `changelog <https://passlib.readthedocs.io/en/stable/history>`_
for a description of what's new in Passlib.
* Visit `PyPI <https://pypi.python.org/pypi/passlib>`_
diff --git a/docs/conf.py b/docs/conf.py
index db77004..fed98d3 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -20,6 +20,11 @@ import sys, os
# make sure root of source dir in sys.path
sys.path.insert(0, os.path.abspath(os.pardir))
+# ignore warnings when documenting deprecated passlib methods
+import warnings
+warnings.filterwarnings("ignore", category=DeprecationWarning,
+ module="passlib[.].*")
+
#=============================================================================
# imports
#=============================================================================
diff --git a/setup.py b/setup.py
index ef27d09..d884fc5 100644
--- a/setup.py
+++ b/setup.py
@@ -88,7 +88,7 @@ providing full-strength password hashing for multi-user applications.
* See the `homepage <https://bitbucket.org/ecollins/passlib>`_
for the latest news and more information.
-* See the `changelog <https://passlib.readthedocs.io/en/stable/history.html>`_
+* See the `changelog <https://passlib.readthedocs.io/en/stable/history>`_
for a description of what's new in Passlib.
All releases are signed with the gpg key
@@ -98,7 +98,7 @@ All releases are signed with the gpg key
KEYWORDS = """\
password secret hash security
crypt md5-crypt
-sha256-crypt sha512-crypt pbkdf2 argon2 scrypt bcrypt
+sha256-crypt sha512-crypt pbkdf2 argon2 scrypt bcrypt
apache htpasswd htdigest
totp 2fa
"""