summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Dent <cdent@anticdent.org>2018-10-24 13:37:51 +0100
committerChris Dent <cdent@anticdent.org>2018-10-24 13:37:51 +0100
commitdc73d5573e6c415fd5589309875221343755fa7b (patch)
tree659efa35be8d698bc4c552ad66a92a28688d5ed2
parent8c174186edba0ab407e18cd5130d3bbb7a939416 (diff)
downloadpaste-git-fix-docs.tar.gz
Prepare docs for publishing to RTFDfix-docs
We'd like to have a stable location for documentation. The destination will be https://pythonpaste.readthedocs.io This change also tries to make sure that there are sufficient warnings throughout about the status of Paste.
-rw-r--r--.gitignore1
-rw-r--r--docs/_static/default.css (renamed from docs/default.css)0
-rw-r--r--docs/_templates/layout.html29
-rw-r--r--docs/community/index.txt4
-rw-r--r--docs/community/mailing-list.txt4
-rw-r--r--docs/community/repository.txt9
-rw-r--r--docs/conf.py2
-rw-r--r--docs/do-it-yourself-framework.txt2
-rw-r--r--docs/download/index.txt13
-rw-r--r--docs/future.txt2
-rw-r--r--docs/index.txt8
-rw-r--r--setup.py6
12 files changed, 32 insertions, 48 deletions
diff --git a/.gitignore b/.gitignore
index 6b57a05..5689180 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
.tox
.coverage
*.egg-info
+docs/_build/
diff --git a/docs/default.css b/docs/_static/default.css
index a570fb6..a570fb6 100644
--- a/docs/default.css
+++ b/docs/_static/default.css
diff --git a/docs/_templates/layout.html b/docs/_templates/layout.html
deleted file mode 100644
index 6ae2d42..0000000
--- a/docs/_templates/layout.html
+++ /dev/null
@@ -1,29 +0,0 @@
-{% extends "!layout.html" %}
-
-{% block extrahead %}
-{{ super() }}
-<link rel="stylesheet" type="text/css"
- href="{{ pathto('_static/paste.css') }}">
-{% endblock %}
-
-{% block sidebartoc %}
-<h3><a href="http://pythonpaste.org/" class="invisible-link">Python Paste</a></h3>
-
-<ul>
-<li><a href="https://bitbucket.org/ianb/pastescript/issues/">Issue tracker</a></li>
-<li><a href="http://pythonpaste.org/">Paste core</a></li>
-<li><a href="http://webob.org/">WebOb</a></li>
-<li><a href="http://pythonpaste.org/deploy/">Paste Deploy</a></li>
-<li><a href="http://pythonpaste.org/script/">Paste Script</a></li>
-<li><a href="http://webtest.pythonpaste.org/">WebTest</a></li>
-<li><a href="http://pythonpaste.org/scripttest/">ScriptType</a></li>
-<li><a href="http://pythonpaste.org/initools/">INITools</a></li>
-<li><a href="http://pythonpaste.org/tempita/">Tempita</a></li>
-<li><a href="http://pythonpaste.org/waitforit/">WaitForIt</a></li>
-<li><a href="http://pythonpaste.org/wphp/">WPHP</a></li>
-<li><a href="http://pythonpaste.org/wsgifilter/">WSGIFilter</a></li>
-<li><a href="http://pythonpaste.org/wsgiproxy/">WSGIProxy</a></li>
-</ul>
-
-{{ super() }}
-{% endblock %}
diff --git a/docs/community/index.txt b/docs/community/index.txt
index 5b30110..5b7c663 100644
--- a/docs/community/index.txt
+++ b/docs/community/index.txt
@@ -1,6 +1,10 @@
Community
=========
+**Much of the Paste community has moved on to other things. These
+links are left for reference, but do not expect to find much activity
+there.**
+
Much of the communication goes on in the `mailing lists
<mailing-list.html>`_; see that page for information on the lists.
diff --git a/docs/community/mailing-list.txt b/docs/community/mailing-list.txt
index 854ec3e..adf1633 100644
--- a/docs/community/mailing-list.txt
+++ b/docs/community/mailing-list.txt
@@ -1,6 +1,10 @@
Mailing Lists
=============
+**Much of the Paste community has moved on to other things. These
+links are left for reference, but do not expect to find much activity
+there.**
+
General discussion and questions should go to:
`paste-users@googlegroups.org <http://groups.google.com/group/paste-users>`_:
diff --git a/docs/community/repository.txt b/docs/community/repository.txt
index b8f3700..5428bf9 100644
--- a/docs/community/repository.txt
+++ b/docs/community/repository.txt
@@ -1,10 +1,7 @@
Repository
==========
-Paste is kept in a Mercurial (hg) repository at
-http://bitbucket.org/ianb/paste
+Paste is kept in a Git repository at
+http://github.com/cdent/paste
-If you are using a command-line Mercurial client, you can check
-it out like::
-
- hg clone http://bitbucket.org/ianb/paste
+Go there to make pull requests and report issues.
diff --git a/docs/conf.py b/docs/conf.py
index e035d50..a2a2f86 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -24,7 +24,7 @@ import sys
extensions = ['sphinx.ext.autodoc']
# Add any paths that contain templates here, relative to this directory.
-templates_path = ['_templates']
+# templates_path = ['_templates']
# The suffix of source filenames.
source_suffix = '.txt'
diff --git a/docs/do-it-yourself-framework.txt b/docs/do-it-yourself-framework.txt
index ae77ec0..23b85ae 100644
--- a/docs/do-it-yourself-framework.txt
+++ b/docs/do-it-yourself-framework.txt
@@ -387,7 +387,7 @@ is a somewhat more thorough implementation of this.
This, like a lot of parts of this (now fairly old) tutorial is
better, more thorough, and easier using `WebOb
- <http://pythonpaste.org/webob/>`_. This particular example looks
+ <https://webob.org/>`_. This particular example looks
like::
from webob import Request
diff --git a/docs/download/index.txt b/docs/download/index.txt
index 01f918f..537e316 100644
--- a/docs/download/index.txt
+++ b/docs/download/index.txt
@@ -16,17 +16,16 @@ are always located on the Cheese Shop pages (listed below).
* `Wareweb <http://pypi.python.org/pypi/Wareweb>`_ (deprecated, use `Pylons
<https://pypi.python.org/pypi/Pylons>`_ instead)
-All the packages are available in the Mercurial repositories rooted in
+All the packages are available in some repositories, many rooted in
http://bitbucket.org/ianb/
-* http://bitbucket.org/ianb/paste
+* https://github.com/cdent/paste
* http://bitbucket.org/ianb/pastescript
* http://bitbucket.org/ianb/pastedeploy
* https://github.com/Pylons/webob
* ... and others
-Use::
-
- hg clone http://bitbucket.org/ianb/paste
-
-to check out a working copy of Paste.
+..note:: Several of these repositories and projects are fairly stale and
+ insufficiently maintained. Work is in progress to get them on
+ life support, but it is unlikely they will ever be active projects
+ again. WebOb is still actively maintained.
diff --git a/docs/future.txt b/docs/future.txt
index 697c750..d98775f 100644
--- a/docs/future.txt
+++ b/docs/future.txt
@@ -4,7 +4,7 @@ The Future Of Paste
Introduction
------------
-Paste has been under development for a while, and has lots of code in it. Too much code! The code is largely decoupled except for some core functions shared by many parts of the code. Those core functions are largely replaced in `WebOb <http://pythonpaste.org/webob/>`_, and replaced with better implementations.
+Paste has been under development for a while, and has lots of code in it. Too much code! The code is largely decoupled except for some core functions shared by many parts of the code. Those core functions are largely replaced in `WebOb <https://webob.org/>`_, and replaced with better implementations.
The future of these pieces is to split them into independent packages, and refactor the internal Paste dependencies to rely instead on WebOb.
diff --git a/docs/index.txt b/docs/index.txt
index 546e9fb..a202b9d 100644
--- a/docs/index.txt
+++ b/docs/index.txt
@@ -1,6 +1,14 @@
Python Paste
============
+This is a new copy of the documentation for Paste. The project is now being
+maintained on limited life-support from https://github.com/cdent/paste
+**Please consider other options.**
+
+Many of the links you will find in these docs will be out of date. If you
+know of a better destination for a link please submit an issue or pull
+request at the GitHub repository above.
+
Contents:
.. toctree::
diff --git a/setup.py b/setup.py
index d023e23..ab8ed29 100644
--- a/setup.py
+++ b/setup.py
@@ -49,9 +49,9 @@ setup(name="Paste",
"Framework :: Paste",
],
keywords='web application server wsgi',
- author="Ian Bicking",
- author_email="ianb@colorstudy.com",
- url="https://pypi.org/project/Paste/",
+ author="Chris Dent",
+ author_email="chris.dent@gmail.com",
+ url="https://pythonpaste.readthedocs.io/",
license="MIT",
packages=find_packages(exclude=['ez_setup', 'examples', 'packages', 'tests*']),
package_data=finddata.find_package_data(