summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Dent <cdent@anticdent.org>2022-06-22 11:20:07 +0100
committerChris Dent <cdent@anticdent.org>2022-06-22 11:20:07 +0100
commit27f25898c8c8cf52fc49175fd8b51e1289000884 (patch)
tree3407ed3d1ba7342546e58bad339cdad1d60d32d5
parent6871824f9f87b63bdf5c863971df4c6a454f105c (diff)
downloadpaste-git-27f25898c8c8cf52fc49175fd8b51e1289000884.tar.gz
Release 3.5.13.5.1
* update tox to include py 39 * replace deprecated threading funcs
-rw-r--r--docs/news.txt8
-rw-r--r--setup.py2
-rw-r--r--tox.ini2
3 files changed, 10 insertions, 2 deletions
diff --git a/docs/news.txt b/docs/news.txt
index d3ccc5d..b232569 100644
--- a/docs/news.txt
+++ b/docs/news.txt
@@ -3,6 +3,14 @@ News
.. contents::
+3.5.1
+-----
+
+* Replace deprecated threading.currentThread, getName and setDaemon
+ with threading.current_thread, name and daemon.
+
+Thanks to hugovk.
+
3.5.0
-----
diff --git a/setup.py b/setup.py
index 436c031..108fccb 100644
--- a/setup.py
+++ b/setup.py
@@ -12,7 +12,7 @@
# - git push
# - python setup.py sdist bdist_wheel upload --sign
-__version__ = '3.5.0'
+__version__ = '3.5.1'
from setuptools import setup, find_packages
import sys, os
diff --git a/tox.ini b/tox.ini
index c4d890a..01cd9d4 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py27, py36, py37, py38, pypy
+envlist = py27, py36, py37, py38, py39, pypy
[testenv]
# For performance, but also for using "source" with coveragepy (https://github.com/nedbat/coveragepy/issues/268).