summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomo <68489118+tomodachi94@users.noreply.github.com>2022-08-24 06:07:02 -0700
committerGitHub <noreply@github.com>2022-08-24 14:07:02 +0100
commit59eaf315d0e25ea8189e63d4f448d9808f8eb85d (patch)
tree7745f0664e6807da0e957269d634e328ec4251af
parentb6e49ce8d9d38e99416e655b43e276e3be84f058 (diff)
downloadpaste-git-59eaf315d0e25ea8189e63d4f448d9808f8eb85d.tar.gz
Add project URLs to PyPI listing (#71)
This was done by adding a dictionary, called project_urls, to the parameters of the setup function in setup.py
-rw-r--r--setup.py5
1 files changed, 5 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 5b4dd4c..9438aab 100644
--- a/setup.py
+++ b/setup.py
@@ -46,6 +46,11 @@ setup(name="Paste",
author="Chris Dent",
author_email="chris.dent@gmail.com",
url="https://pythonpaste.readthedocs.io/",
+ project_urls={
+ "Source": "https://github.com/cdent/paste",
+ "Bug Tracker": "https://github.com/cdent/paste/issues",
+ "Documentation": "https://pythonpaste.readthedocs.io"
+ },
license="MIT",
packages=find_packages(exclude=['ez_setup', 'examples', 'packages', 'tests*']),
package_data=finddata.find_package_data(