summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Hrnčiar <tomas.hrnciar@me.com>2020-09-09 16:26:09 +0200
committerGitHub <noreply@github.com>2020-09-09 15:26:09 +0100
commite65b9b086f28958c8584180a3c74275d6176e468 (patch)
treec5b1cd96f9e0b3e23e534a3c6305a8a486fb38b4
parenta80c388626a3852b58aa1431c3ca1727f58dc3c2 (diff)
downloadpaste-git-e65b9b086f28958c8584180a3c74275d6176e468.tar.gz
New version of setuptools uses `html` module from standart library (#58)
which collides with `paste.util.html`. Instead of inserting it into first position of sys.path, this commit appends it to the end. Building tested in COPR: https://copr.fedorainfracloud.org/coprs/thrnciar/python-setuptools/build/1654052/ Fixes: #57
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 6c7df63..a9c8a68 100644
--- a/setup.py
+++ b/setup.py
@@ -16,7 +16,7 @@ __version__ = '3.4.3'
from setuptools import setup, find_packages
import sys, os
-sys.path.insert(0, os.path.join(os.path.dirname(__file__),
+sys.path.append(os.path.join(os.path.dirname(__file__),
'paste', 'util'))
import finddata