summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorColin Watson <cjwatson@ubuntu.com>2020-01-27 13:32:09 +0000
committerChris Dent <cdent@anticdent.org>2020-01-27 13:32:09 +0000
commite9827316dfb827a8005dbfc9b370edd7d330773e (patch)
treee2e5985d71970f8a23e3ed5807ee98cfb7bcfe3f
parentaaa216c6e0a3c1fd18fccd07ccd4c13230c9f87a (diff)
downloadpaste-git-e9827316dfb827a8005dbfc9b370edd7d330773e.tar.gz
Remove pytest-runner integration (#47)
`pytest-runner` describes itself as deprecated in its own package description, referring to https://github.com/pypa/setuptools/issues/1684. Using it in `setup_requires` means that any other package that depends on Paste has to install `pytest-runner` too, which is fairly heavyweight and unnecessary. (I ran into this when trying to update Launchpad to a less ancient version of Paste.) This does mean that `python setup.py test` no longer works, but, according to the setuptools issue above, that's deprecated anyway. Paste already has `tox` configuration that works well.
-rw-r--r--setup.cfg1
-rw-r--r--setup.py2
2 files changed, 0 insertions, 3 deletions
diff --git a/setup.cfg b/setup.cfg
index 20def47..7300c5b 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -5,7 +5,6 @@ tag_svn_revision = 0
[aliases]
distribute = register sdist bdist_egg upload pudge publish
-test = pytest
[bdist_wheel]
universal=1
diff --git a/setup.py b/setup.py
index 1c64213..c77466e 100644
--- a/setup.py
+++ b/setup.py
@@ -52,9 +52,7 @@ setup(name="Paste",
exclude_directories=finddata.standard_exclude_directories + ('tests',)),
namespace_packages=['paste'],
zip_safe=False,
- setup_requires=['pytest-runner'],
install_requires=['six>=1.4.0'],
- tests_require=['pytest'],
extras_require={
'subprocess': [],
'hotshot': [],