summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorVictor Stinner <victor.stinner@gmail.com>2015-04-21 23:26:38 +0200
committerVictor Stinner <victor.stinner@gmail.com>2015-04-21 23:26:38 +0200
commita8a17ce1d575c26f35b71ef93038c746802cb777 (patch)
tree2f3f9a1c627c9ac84df116b1445f4c1d75deb228 /setup.py
parent43a2852a6c78c6c17db6ce856b844e28f0bc6ef8 (diff)
downloadpaste-a8a17ce1d575c26f35b71ef93038c746802cb777.tar.gz
Add tox.ini to run tests with tox on Python 2.6, 2.7 and 3.4
* MANIFEST.in: add regen-docs & tox.ini
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py13
1 files changed, 12 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 9ff4382..2197f98 100644
--- a/setup.py
+++ b/setup.py
@@ -1,8 +1,19 @@
# Procedure to release a new version:
-# - run tests
+#
+# - run tests: run tox
# - update version in setup.py (__version__)
# - update changelog: docs/news.txt
# - modify setup.py: set RELEASE to True
+# - check that "python setup.py sdist" contains all files tracked by
+# the SCM (Mercurial): update MANIFEST.in if needed
+#
+# - hg ci
+# - hg tag VERSION
+# - hg push
+# - python setup.py register sdist bdist_wheel upload
+#
+# - increment version in setup.py (__version__)
+# - hg ci && hg push
# If true, then the svn revision won't be used to calculate the
# revision (set to True for real releases)