summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorianb <devnull@localhost>2006-01-27 08:29:49 +0000
committerianb <devnull@localhost>2006-01-27 08:29:49 +0000
commitab88f30eecc47620165baeea7f2a16703ed02114 (patch)
tree594b8da6359f8d812fa2e9e0b3734fef6296bc2d /setup.py
parenta9463f9ddbecee26410fdbc48f2dfba26d732c17 (diff)
downloadpaste-ab88f30eecc47620165baeea7f2a16703ed02114.tar.gz
Added a url->username translation function to the app (so we can actually try to log the user in when they complete the process). Added specific hooks for auth_tkt stuff -- should be changed in the future so it is common to all login systems. Made the login_redirect actually redirect externally, not internally. Not sure if that will work with everyone -- I guess not, if they aren't using auth_tkt with the auth_tkt hooks. But I'm not sure how it is supposed to work otherwise either. Maybe there needs to be two settings -- login_redirect and login_external_redirect. Or maybe leaving login_redirect blank should be okay, and that will cause the user to be redirected back to where they came from (another feature that should be added to this)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index d0d91a8..daece09 100644
--- a/setup.py
+++ b/setup.py
@@ -165,7 +165,7 @@ For the latest changes see the `news file
evalerror = paste.evalexception:EvalException
auth_tkt = paste.auth.auth_tkt:make_auth_tkt_middleware
grantip = paste.auth.grantip:make_grantip
- openid = paste.auth.open_id:make_middleware [openid]
+ openid = paste.auth.open_id:make_open_id_middleware [openid]
[paste.server_runner]
http = paste.httpserver:server_runner