summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorIan Bicking <ianb@colorstudy.com>2010-04-01 11:54:10 -0500
committerIan Bicking <ianb@colorstudy.com>2010-04-01 11:54:10 -0500
commitcb0d71678da0b45148c1a15ac86b3d2b3a341634 (patch)
treebb4b81ce722a0ed96455b11574eda62007befd18 /setup.py
parentec6061009bc4ba8f48580d407df5f81b64ff071e (diff)
downloadpaste-cb0d71678da0b45148c1a15ac86b3d2b3a341634.tar.gz
Exclude tests/ from being installed
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 2 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 1270984..6d74157 100644
--- a/setup.py
+++ b/setup.py
@@ -130,7 +130,7 @@ For the latest changes see the `news file
author_email="ianb@colorstudy.com",
url="http://pythonpaste.org",
license="MIT",
- packages=find_packages(exclude=['ez_setup', 'examples', 'packages']),
+ packages=find_packages(exclude=['ez_setup', 'examples', 'packages', 'tests']),
package_data=finddata.find_package_data(),
namespace_packages=['paste'],
zip_safe=False,
@@ -166,7 +166,7 @@ For the latest changes see the `news file
gzip = paste.gzipper:make_gzip_middleware
httpexceptions = paste.httpexceptions:make_middleware
lint = paste.lint:make_middleware
- printdebug = paste.debug.prints:PrintDebugMiddleware
+ printdebug = paste.debug.prints:PrintDebugMiddleware
profile = paste.debug.profile:make_profile_middleware [hotshot]
recursive = paste.recursive:make_recursive_middleware
# This isn't good enough to deserve the name egg:Paste#session:
@@ -191,5 +191,3 @@ For the latest changes see the `news file
http = paste.httpserver:server_runner
""",
)
-
-