summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Piercy <web@stevepiercy.com>2018-11-29 21:45:46 +0900
committerChris Dent <chris.dent@gmail.com>2018-11-29 12:45:46 +0000
commit2f6b25547f93a437a6ba696d764b031951be8fbd (patch)
tree2a657df0559dc5a16be8eb0d42b252d69299491b
parent55cea2c020827e28004f10a63f6b0fb6930b5ca1 (diff)
downloadpastedeploy-git-2f6b25547f93a437a6ba696d764b031951be8fbd.tar.gz
setup.py update (#17)
* update trove classifiers * Replace ' with " for consistency * Update contacts * PEP8 space
-rw-r--r--setup.py71
1 files changed, 36 insertions, 35 deletions
diff --git a/setup.py b/setup.py
index 623b847..fc3bfb0 100644
--- a/setup.py
+++ b/setup.py
@@ -7,56 +7,57 @@ readme_path = os.path.join(here, "README.rst")
readme = open(readme_path).read()
docs_extras = [
- 'Sphinx >= 1.7.5', # Read The Docs minimum version
- 'pylons-sphinx-themes',
+ "Sphinx >= 1.7.5", # Read The Docs minimum version
+ "pylons-sphinx-themes",
]
setup(
- name='PasteDeploy',
- version='1.5.2',
- description='Load, configure, and compose WSGI applications and servers',
+ name="PasteDeploy",
+ version="1.5.2",
+ description="Load, configure, and compose WSGI applications and servers",
long_description=readme,
classifiers=[
- 'Development Status :: 6 - Mature',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: MIT License',
- 'Programming Language :: Python',
- 'Programming Language :: Python :: 2.5',
- 'Programming Language :: Python :: 2.6',
- 'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.1',
- 'Programming Language :: Python :: 3.2',
- 'Programming Language :: Python :: 3.3',
- 'Topic :: Internet :: WWW/HTTP',
- 'Topic :: Internet :: WWW/HTTP :: Dynamic Content',
- 'Topic :: Internet :: WWW/HTTP :: WSGI',
- 'Topic :: Internet :: WWW/HTTP :: WSGI :: Middleware',
- 'Topic :: Software Development :: Libraries :: Python Modules',
- 'Framework :: Paste',
+ "Development Status :: 6 - Mature",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: MIT License",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.4",
+ "Programming Language :: Python :: 3.5",
+ "Programming Language :: Python :: 3.6",
+ "Programming Language :: Python :: 3.7",
+ "Programming Language :: Python :: Implementation :: CPython",
+ "Programming Language :: Python :: Implementation :: PyPy",
+ "Topic :: Internet :: WWW/HTTP",
+ "Topic :: Internet :: WWW/HTTP :: Dynamic Content",
+ "Topic :: Internet :: WWW/HTTP :: WSGI",
+ "Topic :: Internet :: WWW/HTTP :: WSGI :: Middleware",
+ "Topic :: Software Development :: Libraries :: Python Modules",
+ "Framework :: Paste",
],
- keywords='web wsgi application server',
- author='Ian Bicking',
- author_email='ianb@colorstudy.com',
- maintainer='Alex Gronholm',
- maintainer_email='alex.gronholm@nextday.fi',
+ keywords="web wsgi application server",
+ author="Ian Bicking",
+ author_email="pylons-discuss@googlegroups.com",
+ maintainer="Chris Dent",
+ maintainer_email="pylons-discuss@googlegroups.com",
url="https://pylonsproject.org/",
project_urls={
"Documentation": "https://docs.pylonsproject.org/projects/pastedeploy/en/latest/",
"Changelog": "https://docs.pylonsproject.org/projects/pastedeploy/en/latest/news.html",
"Issue Tracker": "https://github.com/Pylons/pastedeploy/issues",
},
- license='MIT',
- namespace_packages=['paste'],
- packages=find_packages(exclude=['tests']),
+ license="MIT",
+ namespace_packages=["paste"],
+ packages=find_packages(exclude=["tests"]),
include_package_data=True,
zip_safe=False,
- setup_requires=['pytest-runner'],
- tests_require=['pytest'],
+ setup_requires=["pytest-runner"],
+ tests_require=["pytest"],
extras_require={
- 'Config': [],
- 'Paste': ['Paste'],
- 'docs': docs_extras,
+ "Config": [],
+ "Paste": ["Paste"],
+ "docs": docs_extras,
},
entry_points="""
[paste.filter_app_factory]