summaryrefslogtreecommitdiff
path: root/docs/conf.py
diff options
context:
space:
mode:
authorSteve Piercy <web@stevepiercy.com>2018-11-26 21:50:17 +0900
committerChris Dent <chris.dent@gmail.com>2018-11-26 12:50:17 +0000
commita207e5c8976e4f7bcf0e80ba4d94ccbf7a7f2670 (patch)
treea5469bfef3d3a81c924b30a77135f23763cf7b61 /docs/conf.py
parenteacb37de3de476c191a4471770ba08ff2939b241 (diff)
downloadpastedeploy-git-a207e5c8976e4f7bcf0e80ba4d94ccbf7a7f2670.tar.gz
Update URLs in setup.py and README (#10)
* Rename to README.rst for better rendering on GitHub * Update URLs in README and setup.py - See #2 and #4 * Add docs_extra to setup.py * Use pylons-sphinx-themes for pylons * Fix broken link to get initial html docs built * Move license.txt to root of repo in hopes that GitHub will find it * Remove obsolete links from navigation * Remove license from docs * Update link to pastescript in README.rst
Diffstat (limited to 'docs/conf.py')
-rw-r--r--docs/conf.py23
1 files changed, 18 insertions, 5 deletions
diff --git a/docs/conf.py b/docs/conf.py
index af16cab..17bdf1c 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -12,6 +12,7 @@
# serve to show the default value.
import sys
+import pylons_sphinx_themes
# If your extensions are in another directory, add it here.
#sys.path.append('some/directory')
@@ -71,10 +72,16 @@ pygments_style = 'sphinx'
# Options for HTML output
# -----------------------
+html_theme = 'pylons'
+html_theme_path = pylons_sphinx_themes.get_html_themes_path()
+html_theme_options = dict(
+ canonical_url='https://docs.pylonsproject.org/projects/pastedeploy/en/latest/'
+)
+
# The style sheet to use for HTML and HTML Help pages. A file of that name
# must exist either in Sphinx' static/ path, or in one of the custom paths
# given in html_static_path.
-html_style = 'default.css'
+# html_style = 'default.css'
# Add any paths that contain custom static files (such as style sheets) here,
# relative to this directory. They are copied after the builtin static files,
@@ -85,15 +92,21 @@ html_static_path = ['_static']
# using the given strftime format.
html_last_updated_fmt = '%b %d, %Y'
-# If true, SmartyPants will be used to convert quotes and dashes to
-# typographically correct entities.
-#html_use_smartypants = True
+# Do not use smart quotes.
+smartquotes = False
# Content template for the index page.
#html_index = ''
# Custom sidebar templates, maps document names to template names.
-#html_sidebars = {}
+# Control display of sidebars
+html_sidebars = { '**': [
+ 'localtoc.html',
+ 'ethicalads.html',
+ 'relations.html',
+ 'sourcelink.html',
+ 'searchbox.html',
+] }
# Additional templates that should be rendered to pages, maps page names to
# template names.