summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorMichael Merickel <michael@merickel.org>2022-05-15 21:09:16 -0500
committerMichael Merickel <michael@merickel.org>2022-05-15 21:23:28 -0500
commit32fb766fa01d436b98e7687f717f6e71c58b9a83 (patch)
tree2fa125334fea9a1ebdbd5381f875368636462afc /pyproject.toml
parentac91794dfb7617b473c9d06d04900debfcdf585e (diff)
downloadpastedeploy-git-32fb766fa01d436b98e7687f717f6e71c58b9a83.tar.gz
blackify/isort/flake8
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml23
1 files changed, 23 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 89a9175..640a0d5 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,3 +1,26 @@
[build-system]
requires = ["setuptools >= 41"]
build-backend = "setuptools.build_meta"
+
+[tool.black]
+target-version = ['py37', 'py38', 'py39', 'py310']
+skip-string-normalization = true
+exclude = '''
+/(
+ \.git
+ | .tox
+)/
+'''
+
+[tool.isort]
+profile = "black"
+multi_line_output = 3
+src_paths = ["src", "tests"]
+skip_glob = ["docs/*"]
+include_trailing_comma = true
+force_grid_wrap = false
+combine_as_imports = true
+line_length = 88
+force_sort_within_sections = true
+default_section = "THIRDPARTY"
+known_first_party = "paste.deploy"