summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorBert JW Regeer <xistence@0x58.com>2022-05-15 20:26:49 -0600
committerGitHub <noreply@github.com>2022-05-15 20:26:49 -0600
commitd4287b56e56b765c9b4fa463cc4dd1191e3f9232 (patch)
tree03bff17fa2a61991aedb4c18fb2a5a1d508c73ed /pyproject.toml
parentac91794dfb7617b473c9d06d04900debfcdf585e (diff)
parentf18450e62b193782648ddba01355f89d36cfc726 (diff)
downloadpastedeploy-git-d4287b56e56b765c9b4fa463cc4dd1191e3f9232.tar.gz
Merge pull request #36 from Pylons/blackify
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml23
1 files changed, 23 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 89a9175..640a0d5 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,3 +1,26 @@
[build-system]
requires = ["setuptools >= 41"]
build-backend = "setuptools.build_meta"
+
+[tool.black]
+target-version = ['py37', 'py38', 'py39', 'py310']
+skip-string-normalization = true
+exclude = '''
+/(
+ \.git
+ | .tox
+)/
+'''
+
+[tool.isort]
+profile = "black"
+multi_line_output = 3
+src_paths = ["src", "tests"]
+skip_glob = ["docs/*"]
+include_trailing_comma = true
+force_grid_wrap = false
+combine_as_imports = true
+line_length = 88
+force_sort_within_sections = true
+default_section = "THIRDPARTY"
+known_first_party = "paste.deploy"