summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorhao huang <huang1hao@gmail.com>2015-03-28 08:10:39 +0000
committerhao huang <huang1hao@gmail.com>2015-03-28 08:10:39 +0000
commitcf7e560f89016a302342821f5071941a09c04283 (patch)
treef8b50954525cf4c063ac09597f9ac576bf92b16e /setup.py
downloadpastedeploy-git-cf7e560f89016a302342821f5071941a09c04283.tar.gz
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py59
1 files changed, 59 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..79f9d70
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,59 @@
+import os
+
+from setuptools import setup, find_packages
+
+here = os.path.dirname(__file__)
+readme_path = os.path.join(here, 'README')
+readme = open(readme_path).read()
+
+
+setup(
+ name='PasteDeploy',
+ version='1.5.2',
+ description='Load, configure, and compose WSGI applications and servers',
+ long_description=readme,
+ classifiers=[
+ 'Development Status :: 6 - Mature',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: MIT License',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2.5',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.1',
+ 'Programming Language :: Python :: 3.2',
+ 'Programming Language :: Python :: 3.3',
+ 'Topic :: Internet :: WWW/HTTP',
+ 'Topic :: Internet :: WWW/HTTP :: Dynamic Content',
+ 'Topic :: Internet :: WWW/HTTP :: WSGI',
+ 'Topic :: Internet :: WWW/HTTP :: WSGI :: Middleware',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ 'Framework :: Paste',
+ ],
+ keywords='web wsgi application server',
+ author='Ian Bicking',
+ author_email='ianb@colorstudy.com',
+ maintainer='Alex Gronholm',
+ maintainer_email='alex.gronholm@nextday.fi',
+ url='http://pythonpaste.org/deploy/',
+ license='MIT',
+ namespace_packages=['paste'],
+ packages=find_packages(exclude=['tests']),
+ include_package_data=True,
+ zip_safe=False,
+ test_suite='nose.collector',
+ tests_require=['nose>=0.11'],
+ extras_require={
+ 'Config': [],
+ 'Paste': ['Paste'],
+ },
+ entry_points="""
+ [paste.filter_app_factory]
+ config = paste.deploy.config:make_config_filter [Config]
+ prefix = paste.deploy.config:make_prefix_middleware
+
+ [paste.paster_create_template]
+ paste_deploy=paste.deploy.paster_templates:PasteDeploy
+ """
+)