summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChris Dent <chris.dent@gmail.com>2018-11-26 11:53:23 +0000
committerGitHub <noreply@github.com>2018-11-26 11:53:23 +0000
commiteacb37de3de476c191a4471770ba08ff2939b241 (patch)
tree0168c24b2e98c747b8c422b66deff075e34a54de /setup.py
parentd18b0527373ca9cdfe90cf340de18e5ab1c1eecf (diff)
downloadpastedeploy-git-eacb37de3de476c191a4471770ba08ff2939b241.tar.gz
Make 'python setup.py test' work (#5)
* Make 'python setup.py test' work Packagers sometimes like to use 'python setup.py test'. This change adjusts setup.py and setup.cfg to allow this to work with pytest instead of nose. To make things work, the settings for coverage need to be moved into tox.ini. A SkipTest in test_config_middleware is changed to its pytest equivalent. * Remove usedevelop from tox.ini Review of improvements to setup.py indicated issues with the tox.ini.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 79f9d70..2ac2606 100644
--- a/setup.py
+++ b/setup.py
@@ -42,8 +42,8 @@ setup(
packages=find_packages(exclude=['tests']),
include_package_data=True,
zip_safe=False,
- test_suite='nose.collector',
- tests_require=['nose>=0.11'],
+ setup_requires=['pytest-runner'],
+ tests_require=['pytest'],
extras_require={
'Config': [],
'Paste': ['Paste'],