summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorChris Dent <chris.dent@gmail.com>2018-11-26 11:53:23 +0000
committerGitHub <noreply@github.com>2018-11-26 11:53:23 +0000
commiteacb37de3de476c191a4471770ba08ff2939b241 (patch)
tree0168c24b2e98c747b8c422b66deff075e34a54de /tests
parentd18b0527373ca9cdfe90cf340de18e5ab1c1eecf (diff)
downloadpastedeploy-git-eacb37de3de476c191a4471770ba08ff2939b241.tar.gz
Make 'python setup.py test' work (#5)
* Make 'python setup.py test' work Packagers sometimes like to use 'python setup.py test'. This change adjusts setup.py and setup.cfg to allow this to work with pytest instead of nose. To make things work, the settings for coverage need to be moved into tox.ini. A SkipTest in test_config_middleware is changed to its pytest equivalent. * Remove usedevelop from tox.ini Review of improvements to setup.py indicated issues with the tox.ini.
Diffstat (limited to 'tests')
-rw-r--r--tests/test_config_middleware.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/test_config_middleware.py b/tests/test_config_middleware.py
index 56c3d04..52ba7d1 100644
--- a/tests/test_config_middleware.py
+++ b/tests/test_config_middleware.py
@@ -20,7 +20,7 @@ def test_error():
try:
from paste.fixture import TestApp
except ImportError:
- raise SkipTest
+ raise pytest.skip('unable to import TestApp')
wrapped = ConfigMiddleware(app_with_exception, {'test': 1})
test_app = TestApp(wrapped)