summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorChris Dent <chris.dent@gmail.com>2018-11-26 11:53:23 +0000
committerGitHub <noreply@github.com>2018-11-26 11:53:23 +0000
commiteacb37de3de476c191a4471770ba08ff2939b241 (patch)
tree0168c24b2e98c747b8c422b66deff075e34a54de /tox.ini
parentd18b0527373ca9cdfe90cf340de18e5ab1c1eecf (diff)
downloadpastedeploy-git-eacb37de3de476c191a4471770ba08ff2939b241.tar.gz
Make 'python setup.py test' work (#5)
* Make 'python setup.py test' work Packagers sometimes like to use 'python setup.py test'. This change adjusts setup.py and setup.cfg to allow this to work with pytest instead of nose. To make things work, the settings for coverage need to be moved into tox.ini. A SkipTest in test_config_middleware is changed to its pytest equivalent. * Remove usedevelop from tox.ini Review of improvements to setup.py indicated issues with the tox.ini.
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini3
1 files changed, 1 insertions, 2 deletions
diff --git a/tox.ini b/tox.ini
index 42469da..9800db2 100644
--- a/tox.ini
+++ b/tox.ini
@@ -2,11 +2,10 @@
envlist = py27, py34, py35, py36, py37, pypy, pypy3
[testenv]
-usedevelop = True
deps =
# Paste works on Python 3 since Paste 2.0
Paste
pytest
pytest-cov
commands =
- py.test {posargs}
+ py.test --cov=paste/deploy --cov-report=xml --cov-report=html --cov-report=term-missing {posargs}