summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Gr?nholm <alex.gronholm@nextday.fi>2011-05-24 04:11:40 +0300
committerAlex Gr?nholm <alex.gronholm@nextday.fi>2011-05-24 04:11:40 +0300
commit066889b037866098e80e55ee5b7676a4220ffb28 (patch)
treea2db6b325e67efef508fc0283581ecd06d44d5e5
parentfb8528a5638a60e697bc7f89c7b774a1dc0e1c00 (diff)
downloadpastedeploy-066889b037866098e80e55ee5b7676a4220ffb28.tar.gz
Removed interfaces and entry point descriptions as useless (entry points are documented in the manual anyway)
-rw-r--r--docs/news.txt3
-rw-r--r--paste/deploy/epdesc.py42
-rw-r--r--paste/deploy/interfaces.py218
-rw-r--r--setup.py9
4 files changed, 3 insertions, 269 deletions
diff --git a/docs/news.txt b/docs/news.txt
index 337347c..d89cc76 100644
--- a/docs/news.txt
+++ b/docs/news.txt
@@ -19,6 +19,9 @@ hg tip
* Dropped Python 2.4 support
+* Removed the ``paste.deploy.epdesc`` and ``paste.deploy.interfaces`` modules
+ -- contact the maintainer if you actually needed them
+
1.3.4
-----
diff --git a/paste/deploy/epdesc.py b/paste/deploy/epdesc.py
deleted file mode 100644
index 5f05175..0000000
--- a/paste/deploy/epdesc.py
+++ /dev/null
@@ -1,42 +0,0 @@
-class AppFactoryDescription(object):
- description = """
- This gives a factory/function that can create WSGI apps
- """
-
-
-class CompositeFactoryDescription(object):
- description = """
- This gives a factory/function that can create WSGI apps, and has
- access to the application creator so that it can in turn fetch
- apps based on name.
- """
-
-
-class FilterAppFactoryDescription(object):
- description = """
- This gives a factory/function that wraps a WSGI application to
- create another WSGI application (typically applying middleware)
- """
-
-
-class FilterFactoryDescription(object):
- description = """
- This gives a factory/function that return a function that can wrap
- a WSGI application and returns another WSGI application.
- paste.filter_app_factory is the same thing with less layers.
- """
-
-
-class ServerFactoryDescription(object):
- description = """
- This gives a factory/function that creates a server, that can be
- called with a WSGI application to run indefinitely.
- paste.server_runner is the same thing with less layers.
- """
-
-
-class ServerRunnerDescription(object):
- description = """
- This gives a factory/function that, given a WSGI application and
- configuration, will serve the application indefinitely.
- """
diff --git a/paste/deploy/interfaces.py b/paste/deploy/interfaces.py
deleted file mode 100644
index 3dbc44e..0000000
--- a/paste/deploy/interfaces.py
+++ /dev/null
@@ -1,218 +0,0 @@
-# (c) 2005 Ian Bicking and contributors; written for Paste (http://pythonpaste.org)
-# Licensed under the MIT license: http://www.opensource.org/licenses/mit-license.php
-
-############################################################
-## Functions
-############################################################
-
-
-def loadapp(uri, name=None, relative_to=None, global_conf=None):
- """
- Provided by ``paste.deploy.loadapp``.
-
- Load the specified URI as a WSGI application (returning IWSGIApp).
- The ``name`` can be in the URI (typically as ``#name``). If it is
- and ``name`` is given, the keyword argument overrides the URI.
-
- If the URI contains a relative filename, then ``relative_to`` is
- used (if ``relative_to`` is not provided, then it is an error).
-
- ``global_conf`` is used to load the configuration (additions
- override the values). ``global_conf`` is copied before modifying.
- """
-
-
-def loadfilter(uri, name=None, relative_to=None, global_conf=None):
- """
- Provided by ``paste.deploy.loadfilter``.
-
- Like ``loadapp()``, except returns in IFilter object.
- """
-
-
-def loadserver(uri, name=None, relative_to=None, global_conf=None):
- """
- Provided by ``paste.deploy.loadserver``.
-
- Like ``loadapp()``, except returns in IServer object.
- """
-
-
-############################################################
-## Factories
-############################################################
-
-
-class IPasteAppFactory(object):
-
- """
- This is the spec for the ``paste.app_factory``
- protocol/entry_point.
- """
-
- def __call__(global_conf, **local_conf):
- """
- Returns a WSGI application (IWSGIAPP) given the global
- configuration and the local configuration passed in as keyword
- arguments.
-
- All keys are strings, but values in local_conf may not be
- valid Python identifiers (if you use ``**kw`` you can still
- capture these values).
- """
-
-
-class IPasteCompositFactory(object):
-
- """
- This is the spec for the ``paste.composit_factory``
- protocol/entry_point.
-
- This also produces WSGI applications, like ``paste.app_factory``,
- but is given more access to the context in which it is loaded.
- """
-
- def __call__(loader, global_conf, **local_conf):
- """
- Like IPasteAppFactory this returns a WSGI application
- (IWSGIApp). The ``loader`` value conforms to the ``ILoader``
- interface, and can be used to load (contextually) more
- applications.
- """
-
-
-class IPasteFilterFactory(object):
-
- """
- This is the spec for the ``paste.filter_factory``
- protocol/entry_point.
- """
-
- def __call__(global_conf, **local_conf):
- """
- Returns a IFilter object.
- """
-
-
-class IPasteFilterAppFactory(object):
-
- """
- This is the spec for the ``paste.filter_app_factory``
- protocol/entry_point.
- """
-
- def __call__(wsgi_app, global_conf, **local_conf):
- """
- Returns a WSGI application that wraps ``wsgi_app``.
-
- Note that paste.deploy creates a wrapper for these
- objects that implement the IFilter interface.
- """
-
-
-class IPasteServerFactory(object):
-
- """
- This is the spec for the ``paste.server_factory``
- protocol/entry_point.
- """
-
- def __call__(global_conf, **local_conf):
- """
- Returns a IServer object.
- """
-
-
-class IPasteServerRunner(object):
-
- """
- This is the spec for the ``paste.server_runner``
- protocol/entry_point.
- """
-
- def __call__(wsgi_app, global_conf, **local_conf):
- """
- Serves the given WSGI application. May serve once, many
- times, forever; nothing about how the server works is
- specified here.
-
- Note that paste.deploy creates a wrapper for these
- objects that implement the IServer interface.
- """
-
-
-class ILoader(object):
-
- """
- This is an object passed into ``IPasteCompositFactory``. It is
- currently implemented in ``paste.deploy.loadwsgi`` by
- ``ConfigLoader`` and ``EggLoader``.
- """
-
- def get_app(name_or_uri, global_conf=None):
- """
- Return an IWSGIApp object. If the loader supports named
- applications, then you can use a simple name; otherwise
- you must use a full URI.
-
- Any global configuration you pass in will be added; you should
- generally pass through the global configuration you received.
- """
-
- def get_filter(name_or_uri, global_conf=None):
- """
- Return an IFilter object, like ``get_app``.
- """
-
- def get_server(name_or_uri, global_conf=None):
- """
- Return an IServer object, like ``get_app``.
- """
-
-
-############################################################
-## Objects
-############################################################
-
-
-class IWSGIApp(object):
-
- """
- This is an application that conforms to `PEP 333
- <http://www.python.org/peps/pep-0333.html>`_: Python Web Server
- Gateway Interface v1.0
- """
-
- def __call__(environ, start_response):
- """
- Calls ``start_response(status_code, header_list)`` and returns
- an iterator for the body of the response.
- """
-
-
-class IFilter(object):
-
- """
- A filter is a simple case of middleware, where an object
- wraps a single WSGI application (IWSGIApp).
- """
-
- def __call__(wsgi_app):
- """
- Returns an IWSGIApp object, typically one that wraps the
- ``wsgi_app`` passed in.
- """
-
-
-class IServer(object):
-
- """
- A simple server interface.
- """
-
- def __call__(wsgi_app):
- """
- Serves the given WSGI application. May serve once, many
- times, forever; nothing about how the server works is
- specified here.
- """
diff --git a/setup.py b/setup.py
index d3127a7..f03bc7a 100644
--- a/setup.py
+++ b/setup.py
@@ -60,14 +60,5 @@ For the latest changes see the `news file
[paste.paster_create_template]
paste_deploy=paste.deploy.paster_templates:PasteDeploy
-
- [paste.entry_point_description]
- paste.app_factory = paste.deploy.epdesc:AppFactoryDescription
- paste.composit_factory = paste.deploy.epdesc:CompositeFactoryDescription
- paste.composite_factory = paste.deploy.epdesc:CompositeFactoryDescription
- paste.filter_app_factory = paste.deploy.epdesc:FilterAppFactoryDescription
- paste.filter_factory = paste.deploy.epdesc:FilterFactoryDescription
- paste.server_factory = paste.deploy.epdesc:ServerFactoryDescription
- paste.server_runner = paste.deploy.epdesc:ServerRunnerDescription
""",
)