summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Stinner <victor.stinner@gmail.com>2015-04-22 23:52:24 +0200
committerVictor Stinner <victor.stinner@gmail.com>2015-04-22 23:52:24 +0200
commit26408ad7397e205daabe4b07cc50c80fdfb830ea (patch)
treebb08d6d42edf8c5d250ecf6a973e9d8717389a3c
parent77d2223bb8585837154983a72eef40433bb1ead1 (diff)
downloadpastedeploy-26408ad7397e205daabe4b07cc50c80fdfb830ea.tar.gz
tox.ini: enable tests on Python 3
Paste is now Python 3 compatible since Paste 2.0.
-rw-r--r--tox.ini12
1 files changed, 4 insertions, 8 deletions
diff --git a/tox.ini b/tox.ini
index 4ac34fd..106434f 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,14 +1,10 @@
[tox]
-envlist = py26,py27,py32,py33,pypy
+envlist = py26,py27,py32,py33,py34,pypy
[testenv]
-deps=nose
+deps=
+ nose
+ # Paste works on Python 3 since Paste 2.0
Paste
commands={envpython} setup.py test
-# Keep it this way until Paste has been ported to py3k
-[testenv:py32]
-deps=nose
-
-[testenv:py33]
-deps=nose