summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Gr?nholm <alex.gronholm@nextday.fi>2013-12-27 18:41:33 +0200
committerAlex Gr?nholm <alex.gronholm@nextday.fi>2013-12-27 18:41:33 +0200
commit7002e260051650db81d8369c1347cf1b678a3c06 (patch)
tree4efbc45c1d70514fc87bd71aa3adccf17c43b5f0
parentec2202668998b63130c242b3b74e054422eea15d (diff)
downloadpastedeploy-7002e260051650db81d8369c1347cf1b678a3c06.tar.gz
Released v1.5.11.5.1
-rw-r--r--docs/conf.py2
-rw-r--r--docs/news.txt15
-rw-r--r--setup.cfg2
-rw-r--r--setup.py53
4 files changed, 48 insertions, 24 deletions
diff --git a/docs/conf.py b/docs/conf.py
index 49aed08..8958fdf 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -42,7 +42,7 @@ copyright = '2011, Ian Bicking and contributors'
# The short X.Y version.
version = '1.5'
# The full version, including alpha/beta/rc tags.
-release = '1.5.1.dev1'
+release = '1.5.1'
# There are two options for replacing |today|: either, you set today to some
# non-false value, then it is used:
diff --git a/docs/news.txt b/docs/news.txt
index c534868..854b5ad 100644
--- a/docs/news.txt
+++ b/docs/news.txt
@@ -1,6 +1,21 @@
Paste Deployment News
=====================
+1.5.1
+-----
+
+* Fixed use of the wrong variable when determining the context protocol
+
+* Fixed invalid import of paste.deploy.Config to paste.deploy.config.Config
+
+* Fixed multi proxy IPs bug in X-Forwarded-For header in PrefixMiddleware
+
+* Fixed TypeError when trying to raise LookupError on Python 3
+
+* Fixed exception reraise on Python 3
+
+Thanks to Alexandre Conrad, Atsushi Odagiri, Pior Bastida and Tres Seaver for their contributions.
+
1.5.0
-----
diff --git a/setup.cfg b/setup.cfg
new file mode 100644
index 0000000..f15c017
--- /dev/null
+++ b/setup.cfg
@@ -0,0 +1,2 @@
+[wheel]
+universal = true
diff --git a/setup.py b/setup.py
index f53a561..b054254 100644
--- a/setup.py
+++ b/setup.py
@@ -1,29 +1,36 @@
+import os
+
from setuptools import setup, find_packages
+here = os.path.dirname(__file__)
+readme_path = os.path.join(here, 'README')
+readme = open(readme_path).read()
+
setup(
name='PasteDeploy',
- version='1.5.1.dev1',
+ version='1.5.1',
description='Load, configure, and compose WSGI applications and servers',
- long_description=open('README').read(),
+ long_description=readme,
classifiers=[
- 'Development Status :: 5 - Production/Stable',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: MIT License',
- 'Programming Language :: Python',
- 'Programming Language :: Python :: 2.5',
- 'Programming Language :: Python :: 2.6',
- 'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.1',
- 'Programming Language :: Python :: 3.2',
- 'Topic :: Internet :: WWW/HTTP',
- 'Topic :: Internet :: WWW/HTTP :: Dynamic Content',
- 'Topic :: Internet :: WWW/HTTP :: WSGI',
- 'Topic :: Internet :: WWW/HTTP :: WSGI :: Middleware',
- 'Topic :: Software Development :: Libraries :: Python Modules',
- 'Framework :: Paste',
- ],
+ 'Development Status :: 6 - Mature',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: MIT License',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2.5',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.1',
+ 'Programming Language :: Python :: 3.2',
+ 'Programming Language :: Python :: 3.3',
+ 'Topic :: Internet :: WWW/HTTP',
+ 'Topic :: Internet :: WWW/HTTP :: Dynamic Content',
+ 'Topic :: Internet :: WWW/HTTP :: WSGI',
+ 'Topic :: Internet :: WWW/HTTP :: WSGI :: Middleware',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ 'Framework :: Paste',
+ ],
keywords='web wsgi application server',
author='Ian Bicking',
author_email='ianb@colorstudy.com',
@@ -38,9 +45,9 @@ setup(
test_suite='nose.collector',
tests_require=['nose>=0.11'],
extras_require={
- 'Config': [],
- 'Paste': ['Paste'],
- },
+ 'Config': [],
+ 'Paste': ['Paste'],
+ },
entry_points="""
[paste.filter_app_factory]
config = paste.deploy.config:make_config_filter [Config]
@@ -48,5 +55,5 @@ setup(
[paste.paster_create_template]
paste_deploy=paste.deploy.paster_templates:PasteDeploy
- """,
+ """
)