summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Gr?nholm <alex.gronholm@nextday.fi>2011-08-15 15:06:50 +0300
committerAlex Gr?nholm <alex.gronholm@nextday.fi>2011-08-15 15:06:50 +0300
commit8aa175c06905ef9d17430e760cfe7e33598f8493 (patch)
tree2b786ecb96aeb7bf07dbd086fd96da846bac2d00
parent212f8b00f0943fa17ca67502bd44cd9152531823 (diff)
downloadpastedeploy-8aa175c06905ef9d17430e760cfe7e33598f8493.tar.gz
Moved the description to README, switched version to development
-rw-r--r--README11
-rw-r--r--docs/conf.py2
-rw-r--r--setup.py62
3 files changed, 37 insertions, 38 deletions
diff --git a/README b/README
new file mode 100644
index 0000000..291a026
--- /dev/null
+++ b/README
@@ -0,0 +1,11 @@
+This tool provides code to load WSGI applications and servers from
+URIs; these URIs can refer to Python Eggs for INI-style configuration
+files. `Paste Script <http://pythonpaste.org/script>`_ provides
+commands to serve applications based on this configuration file.
+
+The latest version is available in a `Mercurial repository
+<http://bitbucket.org/ianb/pastedeploy>`_ (or a `tarball
+<http://bitbucket.org/ianb/pastedeploy/get/tip.gz#egg=PasteDeploy-dev>`_).
+
+For the latest changes see the `news file
+<http://pythonpaste.org/deploy/news.html>`_. \ No newline at end of file
diff --git a/docs/conf.py b/docs/conf.py
index bd009e9..49aed08 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -42,7 +42,7 @@ copyright = '2011, Ian Bicking and contributors'
# The short X.Y version.
version = '1.5'
# The full version, including alpha/beta/rc tags.
-release = '1.5.0'
+release = '1.5.1.dev1'
# There are two options for replacing |today|: either, you set today to some
# non-false value, then it is used:
diff --git a/setup.py b/setup.py
index 63e4600..f53a561 100644
--- a/setup.py
+++ b/setup.py
@@ -2,46 +2,34 @@ from setuptools import setup, find_packages
setup(
- name="PasteDeploy",
- version='1.5.0',
- description="Load, configure, and compose WSGI applications and servers",
- long_description="""\
-This tool provides code to load WSGI applications and servers from
-URIs; these URIs can refer to Python Eggs for INI-style configuration
-files. `Paste Script <http://pythonpaste.org/script>`_ provides
-commands to serve applications based on this configuration file.
-
-The latest version is available in a `Mercurial repository
-<http://bitbucket.org/ianb/pastedeploy>`_ (or a `tarball
-<http://bitbucket.org/ianb/pastedeploy/get/tip.gz#egg=PasteDeploy-dev>`_).
-
-For the latest changes see the `news file
-<http://pythonpaste.org/deploy/news.html>`_.
-""",
+ name='PasteDeploy',
+ version='1.5.1.dev1',
+ description='Load, configure, and compose WSGI applications and servers',
+ long_description=open('README').read(),
classifiers=[
- "Development Status :: 5 - Production/Stable",
- "Intended Audience :: Developers",
- "License :: OSI Approved :: MIT License",
- "Programming Language :: Python",
- "Programming Language :: Python :: 2.5",
- "Programming Language :: Python :: 2.6",
- "Programming Language :: Python :: 2.7",
- "Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.1",
- "Programming Language :: Python :: 3.2",
- "Topic :: Internet :: WWW/HTTP",
- "Topic :: Internet :: WWW/HTTP :: Dynamic Content",
- "Topic :: Internet :: WWW/HTTP :: WSGI",
- "Topic :: Internet :: WWW/HTTP :: WSGI :: Middleware",
- "Topic :: Software Development :: Libraries :: Python Modules",
- "Framework :: Paste",
+ 'Development Status :: 5 - Production/Stable',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: MIT License',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2.5',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.1',
+ 'Programming Language :: Python :: 3.2',
+ 'Topic :: Internet :: WWW/HTTP',
+ 'Topic :: Internet :: WWW/HTTP :: Dynamic Content',
+ 'Topic :: Internet :: WWW/HTTP :: WSGI',
+ 'Topic :: Internet :: WWW/HTTP :: WSGI :: Middleware',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ 'Framework :: Paste',
],
keywords='web wsgi application server',
- author="Ian Bicking",
- author_email="ianb@colorstudy.com",
- maintainer="Alex Gronholm",
- maintainer_email="alex.gronholm@nextday.fi",
- url="http://pythonpaste.org/deploy/",
+ author='Ian Bicking',
+ author_email='ianb@colorstudy.com',
+ maintainer='Alex Gronholm',
+ maintainer_email='alex.gronholm@nextday.fi',
+ url='http://pythonpaste.org/deploy/',
license='MIT',
namespace_packages=['paste'],
packages=find_packages(exclude=['tests']),