summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorIan Bicking <ianb@colorstudy.com>2010-09-16 12:31:17 -0400
committerIan Bicking <ianb@colorstudy.com>2010-09-16 12:31:17 -0400
commit110e07e180fcfc758c0288fa47a1cf1c101451bf (patch)
treece177220221ad08a886efaa85dc7eeee90c6cb23 /setup.py
parent6822d899ac089f4478b696f6889c658bc0e69c45 (diff)
downloadpastedeploy-110e07e180fcfc758c0288fa47a1cf1c101451bf.tar.gz
Remove setup.cfg, which wasn't being (usefully) used, and add finddata to remove need for svn/include_package_data1.3.4
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 8 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 3ea49fe..1959175 100644
--- a/setup.py
+++ b/setup.py
@@ -2,6 +2,12 @@ from setuptools import setup, find_packages
version = '1.3.4'
+import os
+
+here = os.path.dirname(os.path.abspath(__file__))
+finddata_py = os.path.join(here, 'tests', 'finddata.py')
+execfile(finddata_py)
+
setup(
name="PasteDeploy",
version=version,
@@ -38,7 +44,8 @@ For the latest changes see the `news file
license='MIT',
namespace_packages=['paste'],
packages=find_packages(exclude='tests'),
- include_package_data=True,
+ package_data=find_package_data(
+ exclude_directories=standard_exclude_directories + ('tests',)),
zip_safe=False,
test_suite='nose.collector',
tests_require=['nose>=0.11'],