summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py53
1 files changed, 30 insertions, 23 deletions
diff --git a/setup.py b/setup.py
index f53a561..79f9d70 100644
--- a/setup.py
+++ b/setup.py
@@ -1,29 +1,36 @@
+import os
+
from setuptools import setup, find_packages
+here = os.path.dirname(__file__)
+readme_path = os.path.join(here, 'README')
+readme = open(readme_path).read()
+
setup(
name='PasteDeploy',
- version='1.5.1.dev1',
+ version='1.5.2',
description='Load, configure, and compose WSGI applications and servers',
- long_description=open('README').read(),
+ long_description=readme,
classifiers=[
- 'Development Status :: 5 - Production/Stable',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: MIT License',
- 'Programming Language :: Python',
- 'Programming Language :: Python :: 2.5',
- 'Programming Language :: Python :: 2.6',
- 'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.1',
- 'Programming Language :: Python :: 3.2',
- 'Topic :: Internet :: WWW/HTTP',
- 'Topic :: Internet :: WWW/HTTP :: Dynamic Content',
- 'Topic :: Internet :: WWW/HTTP :: WSGI',
- 'Topic :: Internet :: WWW/HTTP :: WSGI :: Middleware',
- 'Topic :: Software Development :: Libraries :: Python Modules',
- 'Framework :: Paste',
- ],
+ 'Development Status :: 6 - Mature',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: MIT License',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2.5',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.1',
+ 'Programming Language :: Python :: 3.2',
+ 'Programming Language :: Python :: 3.3',
+ 'Topic :: Internet :: WWW/HTTP',
+ 'Topic :: Internet :: WWW/HTTP :: Dynamic Content',
+ 'Topic :: Internet :: WWW/HTTP :: WSGI',
+ 'Topic :: Internet :: WWW/HTTP :: WSGI :: Middleware',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ 'Framework :: Paste',
+ ],
keywords='web wsgi application server',
author='Ian Bicking',
author_email='ianb@colorstudy.com',
@@ -38,9 +45,9 @@ setup(
test_suite='nose.collector',
tests_require=['nose>=0.11'],
extras_require={
- 'Config': [],
- 'Paste': ['Paste'],
- },
+ 'Config': [],
+ 'Paste': ['Paste'],
+ },
entry_points="""
[paste.filter_app_factory]
config = paste.deploy.config:make_config_filter [Config]
@@ -48,5 +55,5 @@ setup(
[paste.paster_create_template]
paste_deploy=paste.deploy.paster_templates:PasteDeploy
- """,
+ """
)