summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Petrello <lists@ryanpetrello.com>2015-05-21 10:26:03 -0700
committerRyan Petrello <lists@ryanpetrello.com>2015-05-21 12:29:17 -0700
commit26d1d59aec72d3123cbff8dc929f200a198457fb (patch)
tree5d8857aa55433b3f6528d31a0a0e28105ac438c9
parente7b7daf44e36229d5dada553db3138c2963a08ed (diff)
downloadpecan-26d1d59aec72d3123cbff8dc929f200a198457fb.tar.gz
Fix broken wsme-stable tests.
Change-Id: If9824e18b83a5f273cb727193cb632629b1f0ea1
-rw-r--r--tox.ini7
1 files changed, 6 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index 9a50acd..d479d36 100644
--- a/tox.ini
+++ b/tox.ini
@@ -94,8 +94,13 @@ commands=pecan create testing123 rest-api
[testenv:wsme-stable]
basepython = python2.7
deps = nose
+ ipaddr
+ simplegeneric
+changedir = {envdir}/build/wsme
commands = pip install --build {envdir}/build --pre --no-clean --no-use-wheel wsme
- nosetests -v {envdir}/build/wsme/tests/pecantest
+ {envdir}/bin/python setup.py develop
+ {envdir}/bin/pip install -U {toxinidir} # install pecan-dev
+ nosetests -v tests/pecantest
[testenv:wsme-tip]
basepython = python2.7