summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Petrello <lists@ryanpetrello.com>2015-05-27 16:18:20 -0400
committerRyan Petrello <lists@ryanpetrello.com>2015-05-27 16:35:36 -0400
commit74995b12c52ef0f433a0ca0ba01ee01109dedbae (patch)
tree43932b55abeb680fc49f7b9a5f35434e01fff4c6
parent0dbaa162b790a1d68ac7a4a4de8f641c01b3ff44 (diff)
downloadpecan-74995b12c52ef0f433a0ca0ba01ee01109dedbae.tar.gz
Version increment.
Change-Id: Id2088317d47dc43d0e58869fbc4fa20cee98c7e9
-rw-r--r--docs/source/changes.rst26
-rw-r--r--setup.py2
2 files changed, 27 insertions, 1 deletions
diff --git a/docs/source/changes.rst b/docs/source/changes.rst
index 5cf6f4c..ce3a3aa 100644
--- a/docs/source/changes.rst
+++ b/docs/source/changes.rst
@@ -1,3 +1,29 @@
+0.9.0
+=====
+* Support for Python 3.2 has been dropped.
+* Added a new feature which allows users to specify custom path segments for
+ controllers. This is especially useful for path segments that are not
+ valid Python identifiers (such as path segments that include certain
+ punctuation characters, like `/some/~path~/`).
+* Added a new configuration option, `app.debugger`, which allows developers to
+ specify an alternative debugger to `pdb` (e.g., `ipdb`) when performing
+ interactive debugging with pecan's `DebugMiddleware`.
+* Changed new quickstart pecan projects to default the `pecan` log level to
+ `DEBUG` for development.
+* Fixed a bug that prevented `staticmethods` from being used as controllers.
+* Fixed a decoding bug in the way pecan handles certain quoted URL path
+ segments and query strings.
+* Fixed several bugs in the way pecan handles Unicode path segments (for
+ example, now you can define pecan routes that contain emoji characters).
+* Fixed several bugs in RestController that caused it to return `HTTP 404 Not
+ Found` rather than `HTTP 405 Method Not Allowed`. Additionally,
+ RestController now returns valid `Allow` headers when `HTTP 405 Method Not
+ Allowed` is returned.
+* Fixed a bug which allowed special pecan methods (`_route`, `_lookup`,
+ `_default`) to be marked as generic REST methods.
+* Added more emphasis in pecan's documentation to the need for `debug=False` in
+ production deployments.
+
0.8.3
=====
* Changed pecan to more gracefully handle a few odd request encoding edge
diff --git a/setup.py b/setup.py
index f72b539..a0f4d68 100644
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,7 @@ import platform
from setuptools import setup, find_packages
-version = '0.8.3'
+version = '0.9.0'
#
# determine requirements