summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Petrello <lists@ryanpetrello.com>2015-01-12 15:19:08 -0500
committerRyan Petrello <lists@ryanpetrello.com>2015-01-12 15:19:08 -0500
commit868c28d031aa29fb1d0238885561b9c42b77bd54 (patch)
treec4879346042b3688864b6ea30b7298fd909e2929
parentb98aac0abca66b303bd0d1d81d5a5bebd08538a2 (diff)
downloadpecan-868c28d031aa29fb1d0238885561b9c42b77bd54.tar.gz
Version increment.
Change-Id: I310bfb38ed550e7e5932988ba21602bbea689e83
-rw-r--r--docs/source/changes.rst11
-rw-r--r--setup.py2
2 files changed, 12 insertions, 1 deletions
diff --git a/docs/source/changes.rst b/docs/source/changes.rst
index dd374a0..8e389ba 100644
--- a/docs/source/changes.rst
+++ b/docs/source/changes.rst
@@ -1,3 +1,14 @@
+0.8.3
+=====
+* Changed pecan to more gracefully handle a few odd request encoding edge
+ cases. Now pecan applications respond with an HTTP 400 (rather than an
+ uncaught UnicodeDecodeError, resulting in an HTTP 500) when:
+ - HTTP POST requests are composed of non-Unicode data
+ - Request paths contain invalid percent-encoded characters, e.g.,
+ ``/some/path/%aa/``
+* Improved verbosity for import-related errors in pecan configuration files,
+ especially those involving relative imports.
+
0.8.2
=====
* Fixes a bug that breaks support for multi-value query string variables (e.g.,
diff --git a/setup.py b/setup.py
index 0c621c0..248b25c 100644
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,7 @@ import platform
from setuptools import setup, find_packages
-version = '0.8.2'
+version = '0.8.3'
#
# determine requirements