summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Petrello <lists@ryanpetrello.com>2015-05-21 12:42:56 -0700
committerRyan Petrello <lists@ryanpetrello.com>2015-05-26 09:16:20 -0700
commitccb5f75e13ade560a09fee0651f444954d62a8e5 (patch)
tree741e2809db784bec9a9ae27b54658389d38acb4f
parentac6b72e441f2c01fadf0d34ce0f8c38b244007e8 (diff)
downloadpecan-ccb5f75e13ade560a09fee0651f444954d62a8e5.tar.gz
Gate against latest stable projects.
Change-Id: I3be22d88872c65be07bde495c5bd9fd7b33df397
-rw-r--r--tox.ini26
1 files changed, 17 insertions, 9 deletions
diff --git a/tox.ini b/tox.ini
index d479d36..fc8589d 100644
--- a/tox.ini
+++ b/tox.ini
@@ -111,7 +111,7 @@ commands = nosetests -v tests/pecantest
[testenv:ceilometer-stable]
basepython = python2.7
-deps = -egit+http://git.openstack.org/openstack/ceilometer@stable/icehouse#egg=ceilometer
+deps = -egit+http://git.openstack.org/openstack/ceilometer@stable/kilo#egg=ceilometer
changedir = {envdir}/src/ceilometer
commands = tox -e py27 --notest # ensure a virtualenv is built
{envdir}/src/ceilometer/.tox/py27/bin/pip install -U {toxinidir} # install pecan-dev
@@ -127,7 +127,7 @@ commands = tox -e py27 --notest # ensure a virtualenv is built
[testenv:ironic-stable]
basepython = python2.7
-deps = -egit+http://git.openstack.org/openstack/ironic@stable/icehouse#egg=ironic
+deps = -egit+http://git.openstack.org/openstack/ironic@stable/kilo#egg=ironic
changedir = {envdir}/src/ironic
commands = tox -e py27 --notest # ensure a virtualenv is built
{envdir}/src/ironic/.tox/py27/bin/pip install -U {toxinidir} # install pecan-dev
@@ -141,25 +141,25 @@ commands = tox -e py27 --notest # ensure a virtualenv is built
{envdir}/src/ironic/.tox/py27/bin/pip install -U {toxinidir} # install pecan-dev
tox -e py27
-[testenv:barbican-tip]
+[testenv:barbican-stable]
basepython = python2.7
-deps = -egit+http://git.openstack.org/openstack/barbican#egg=barbican
+deps = -egit+http://git.openstack.org/openstack/barbican@stable/kilo#egg=barbican
changedir = {envdir}/src/barbican
commands = tox -e py27 --notest # ensure a virtualenv is built
{envdir}/src/barbican/.tox/py27/bin/pip install -U {toxinidir} # install pecan-dev
tox -e py27
-[testenv:storyboard-tip]
+[testenv:barbican-tip]
basepython = python2.7
-deps = -egit+http://git.openstack.org/openstack-infra/storyboard#egg=storyboard
-changedir = {envdir}/src/storyboard
+deps = -egit+http://git.openstack.org/openstack/barbican#egg=barbican
+changedir = {envdir}/src/barbican
commands = tox -e py27 --notest # ensure a virtualenv is built
- {envdir}/src/storyboard/.tox/py27/bin/pip install -U {toxinidir} # install pecan-dev
+ {envdir}/src/barbican/.tox/py27/bin/pip install -U {toxinidir} # install pecan-dev
tox -e py27
[testenv:designate-stable]
basepython = python2.7
-deps = -egit+http://git.openstack.org/openstack/designate@stable/icehouse#egg=designate
+deps = -egit+http://git.openstack.org/openstack/designate@stable/kilo#egg=designate
changedir = {envdir}/src/designate
commands = tox -e py27 --notest # ensure a virtualenv is built
{envdir}/src/designate/.tox/py27/bin/pip install -U {toxinidir} # install pecan-dev
@@ -173,6 +173,14 @@ commands = tox -e py27 --notest # ensure a virtualenv is built
{envdir}/src/designate/.tox/py27/bin/pip install -U {toxinidir} # install pecan-dev
tox -e py27
+[testenv:storyboard-tip]
+basepython = python2.7
+deps = -egit+http://git.openstack.org/openstack-infra/storyboard#egg=storyboard
+changedir = {envdir}/src/storyboard
+commands = tox -e py27 --notest # ensure a virtualenv is built
+ {envdir}/src/storyboard/.tox/py27/bin/pip install -U {toxinidir} # install pecan-dev
+ tox -e py27
+
[testenv:pep8]
deps = pep8
commands = pep8 --repeat --show-source pecan setup.py --ignore=E402