summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormarkmcclain <mark.mcclain@dreamhost.com>2013-07-08 14:30:59 -0700
committermarkmcclain <mark.mcclain@dreamhost.com>2013-07-08 14:30:59 -0700
commitf5269b65e2f318e6cb17f5737ad838df25d7ac00 (patch)
tree2fdaf161b5deecb716701df8ad086b9738d05372
parentbcca38591e723a65046366ab7d3172e9bbb7a823 (diff)
parent0629489d95b80a2e86ad0bddd59161158b62da4b (diff)
downloadpecan-f5269b65e2f318e6cb17f5737ad838df25d7ac00.tar.gz
Merge pull request #219 from ryanpetrello/next
Jinja 2.7 removed support for Python 3.2
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 512edd7..102c0cf 100644
--- a/setup.py
+++ b/setup.py
@@ -43,7 +43,6 @@ except:
tests_require = requirements + [
'virtualenv',
- 'Jinja2',
'gunicorn',
'mock'
]
@@ -58,6 +57,9 @@ else:
# Genshi added Python3 support in 0.7
tests_require += ['Genshi>=0.7']
+if sys.version_info < (3, 0) or sys.version_info >= (3, 3):
+ tests_require += ['Jinja2']
+
#
# call setup
#