summaryrefslogtreecommitdiff
path: root/docs
diff options
context:
space:
mode:
authorAlfredo Deza <alfredodeza@gmail.com>2010-11-26 11:56:47 -0500
committerAlfredo Deza <alfredodeza@gmail.com>2010-11-26 11:56:47 -0500
commite28d00cc594b88949cb7da70e4e176e57436094c (patch)
tree73ca853e8a34b67cf013dd8b98503a1f2976a1bd /docs
parent99327df98700b965d64f702d0f02d54363bbb940 (diff)
downloadpecan-e28d00cc594b88949cb7da70e4e176e57436094c.tar.gz
finished basic installation and testing instructions
Diffstat (limited to 'docs')
-rw-r--r--docs/source/app_engine.rst10
-rw-r--r--docs/source/index.rst2
-rw-r--r--docs/source/installation.rst24
3 files changed, 25 insertions, 11 deletions
diff --git a/docs/source/app_engine.rst b/docs/source/app_engine.rst
index c2bccd3..f80dea4 100644
--- a/docs/source/app_engine.rst
+++ b/docs/source/app_engine.rst
@@ -19,16 +19,16 @@ Pecan has a few dependencies and one of them is already supported by App Engine
so no need to grab that. Just so you are aware, this is the list of things that you absolutely need
to grab:
- * simplegeneric >= 0.7
- * Paste >= 1.7.5.1
+ * simplegeneric == 0.7
+ * Paste == 1.7.5.1
These are optional, depending on the templating engine you want to use. However, depending on your choice,
you might want to check the engine's dependencies as well. The only engine from this list that doesn't require
a dependency is Kajiki.
- * Genshi >= 0.6
- * Kajiki >= 0.2.2
- * Mako >= 0.3
+ * Genshi == 0.6
+ * Kajiki == 0.3.1
+ * Mako == 0.3
From this point forward, we will assume you are getting Kajiki, to avoid describing third party dependencies.
diff --git a/docs/source/index.rst b/docs/source/index.rst
index c48fe8b..a6a8e31 100644
--- a/docs/source/index.rst
+++ b/docs/source/index.rst
@@ -15,7 +15,7 @@ Contents:
.. toctree::
:maxdepth: 2
- installtion.rst
+ installation.rst
routing.rst
configuration.rst
templates.rst
diff --git a/docs/source/installation.rst b/docs/source/installation.rst
index 09f0ec3..930842d 100644
--- a/docs/source/installation.rst
+++ b/docs/source/installation.rst
@@ -9,7 +9,7 @@ Pecan can be isolated from other packages is best practice.
To get started with an environment for Pecan, create a virtual environment for
it without any site-packages that might pollute::
- virtualenv --no-sitpackages pecan-env
+ virtualenv --no-site-packages pecan-env
cd pecan-env
source bin/activate
@@ -24,8 +24,22 @@ But we do not have Pecan yet, so let's grab it from PYPI::
After a lot of output, you should have Pecan successfully installed and ready
to use.
-.. note::
- If you want to run the development (unstable) version of Pecan you will
- need GIT and clone the repo from: https://github.com/cleverdevil/pecan.git
-
+Development (Unstable) Version
+------------------------------
+If you want to run the development version of Pecan you will
+need GIT installed and clone the repo from github::
+
+ git clone https://github.com/cleverdevil/pecan.git
+
+If you are still in the *pecan-dev* virtual environment that we created before,
+you should call ``setup.py`` to install::
+
+ python setup.py develop
+
+
+Testing
+=======
+For testing purposes, we use `py.test <http://pytest.org/>`_ and
+WebTest, so make sure you have those installed in your environment before
+running the tests.