summaryrefslogtreecommitdiff
path: root/docs
diff options
context:
space:
mode:
authorJoe D'Andrea <jdandrea@research.att.com>2015-04-28 11:33:49 -0400
committerJoe D'Andrea <jdandrea@research.att.com>2015-04-29 12:09:09 -0400
commitec7bdc432dd8be86a4d9e9d20cf35013ca295e86 (patch)
tree251160fdaa62d6b905ca0a068a957862843682a5 /docs
parent87b8d00a2ebcb6b2ff3af567249d5065ed135bbd (diff)
downloadpecan-ec7bdc432dd8be86a4d9e9d20cf35013ca295e86.tar.gz
make_app() now uses the debugger param in DebugMiddleware()
Setting app.debugger in setup.py now takes proper effect. A warning is issued if the entry point is not callable. Change-Id: I58a860b8ef0e1cb956b4554071275c024a1949d2 Closes-Bug: #1449573
Diffstat (limited to 'docs')
-rw-r--r--docs/source/development.rst15
1 files changed, 14 insertions, 1 deletions
diff --git a/docs/source/development.rst b/docs/source/development.rst
index f4e3217..db9bd84 100644
--- a/docs/source/development.rst
+++ b/docs/source/development.rst
@@ -29,11 +29,24 @@ browser for easy debugging:
To further aid in debugging, the middleware includes the ability to repeat the
offending request, automatically inserting a breakpoint, and dropping your
-console into the Python debugger, ``pdb``:
+console into the Python debugger, ``pdb.post_mortem``:
.. figure:: debug-middleware-2.png
:alt: Pecan debug middleware request debugger.
+You can also use any debugger with a suitable ``post_mortem`` entry point.
+For example, to use the `PuDB Debugger <http://pypi.python.org/pypi/pudb>`_,
+set ``debugger`` like so::
+
+ import pudb
+
+ app = {
+ ...
+ 'debug': True,
+ 'debugger': pudb.post_mortem,
+ ...
+ }
+
.. seealso::
Refer to the `pdb documentation