summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--docs/source/changes.rst15
-rw-r--r--setup.py2
2 files changed, 15 insertions, 2 deletions
diff --git a/docs/source/changes.rst b/docs/source/changes.rst
index 59fc150..75f22ec 100644
--- a/docs/source/changes.rst
+++ b/docs/source/changes.rst
@@ -1,9 +1,22 @@
+0.5.0
+=====
+* This release adds formal support for pypy.
+* Added colored request logging to the `pecan serve` command.
+* Added a scaffold for easily generating a basic REST API.
+* Added the ability to pass arbitrary keyword arguments to
+ `pecan.testing.load_test_app`.
+* Fixed a recursion-related bug in the error document middleware.
+* Fixed a bug in the `gunicorn_pecan` command that caused `threading.local`
+ data to leak between eventlet/gevent green threads.
+* Improved documentation through fixes and narrative tutorials for sample pecan
+ applications.
+
0.4.5
=====
* Fixed a trailing slash bug for `RestController`s that have a `_lookup` method.
* Cleaned up the WSGI app reference from the threadlocal state on every request
(to avoid potential memory leaks, especially when testing).
-* Improved pecan documentation and correctd intersphinx references.
+* Improved pecan documentation and corrected intersphinx references.
* pecan supports Python 3.4.
0.4.4
diff --git a/setup.py b/setup.py
index 468c1ef..02cbc6b 100644
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,7 @@ import platform
from setuptools import setup, find_packages
-version = '0.4.5'
+version = '0.5.0'
#
# determine requirements