summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--docs/source/changes.rst13
-rw-r--r--setup.py2
2 files changed, 14 insertions, 1 deletions
diff --git a/docs/source/changes.rst b/docs/source/changes.rst
index 9450e43..0fa3db9 100644
--- a/docs/source/changes.rst
+++ b/docs/source/changes.rst
@@ -1,3 +1,16 @@
+0.7.0
+=====
+* Fixed an edge case in RestController routing which should have returned an
+ HTTP 400 but was instead raising an exception (and thus, HTTP 500).
+* Fixed an incorrect root logger configuration for quickstarted pecan projects.
+* Added `pecan.state.arguments`, a new feature for inspecting controller call
+ arguments.
+* Fixed an infinite recursion error in PecanHook application. Subclassing both
+ `rest.RestController` and `hooks.HookController` resulted in an infinite
+ recursion error in hook application (which prevented applications from
+ starting).
+* Pecan's tests are now included in its source distribution.
+
0.6.1
=====
* Fixed a bug which causes pecan to mistakenly return HTTP 204 for non-empty
diff --git a/setup.py b/setup.py
index c010b76..a0234ac 100644
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,7 @@ import platform
from setuptools import setup, find_packages
-version = '0.6.1'
+version = '0.7.0'
#
# determine requirements