summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py34
1 files changed, 29 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 9d1f5fc..3bb1ff5 100644
--- a/setup.py
+++ b/setup.py
@@ -1,8 +1,8 @@
import sys
+
from setuptools import setup, find_packages
-from setuptools.command.test import test as TestCommand
-version = '0.2.4'
+version = '0.3.0b'
#
# determine requirements
@@ -11,7 +11,8 @@ requirements = [
"WebOb >= 1.2dev", # py3 compat
"simplegeneric >= 0.8", # py3 compat
"Mako >= 0.4.0",
- "WebTest >= 1.3.1" # py3 compat
+ "WebTest >= 1.3.1", # py3 compat
+ "six"
]
try:
@@ -23,14 +24,25 @@ except:
requirements.append("simplejson >= 2.1.1")
try:
+ from logging.config import dictConfig # noqa
+except ImportError:
+ #
+ # This was introduced in Python 2.7 - the logutils package contains
+ # a backported replacement for 2.6
+ #
+ requirements.append('logutils')
+
+try:
import argparse # noqa
except:
+ #
+ # This was introduced in Python 2.7 - the argparse package contains
+ # a backported replacement for 2.6
+ #
requirements.append('argparse')
tests_require = requirements + [
'virtualenv',
- 'Genshi',
- 'Kajiki',
'Jinja2',
'gunicorn',
'mock'
@@ -38,6 +50,14 @@ tests_require = requirements + [
if sys.version_info < (2, 7):
tests_require += ['unittest2']
+if sys.version_info < (3, 0):
+ # These don't support Python3 yet - don't run their tests
+ tests_require += ['Kajiki']
+ tests_require += ['Genshi']
+else:
+ # Genshi added Python3 support in 0.7
+ tests_require += ['Genshi>=0.7']
+
#
# call setup
#
@@ -58,8 +78,12 @@ setup(
'Operating System :: Microsoft :: Windows',
'Operating System :: POSIX',
'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.2',
+ 'Programming Language :: Python :: 3.3',
'Topic :: Internet :: WWW/HTTP :: WSGI',
'Topic :: Software Development :: Libraries :: Application Frameworks'
],