summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini30
1 files changed, 28 insertions, 2 deletions
diff --git a/tox.ini b/tox.ini
index 3c83bc2..951b808 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py26,py27,scaffolds-26,scaffolds-27,pep8
+envlist = py26,py27,py32,py33,scaffolds-26,scaffolds-27,scaffolds-32,scaffolds-33,pep8
[testenv]
commands={envpython} setup.py test -v
@@ -26,6 +26,32 @@ commands=pecan create testing123
pep8 --repeat --show-source testing123/setup.py testing123/testing123
{envpython} {toxinidir}/pecan/tests/scaffold_builder.py
+[testenv:scaffolds-32]
+basepython = python3.2
+deps = pep8
+ gunicorn
+changedir={[testenv:scaffolds-26]changedir}
+commands=pecan create testing123
+ curl "http://python-distribute.org/distribute_setup.py" -O
+ {envpython} distribute_setup.py
+ {envpython} testing123/setup.py install
+ {envpython} testing123/setup.py test -q
+ pep8 --repeat --show-source testing123/setup.py testing123/testing123
+ {envpython} {toxinidir}/pecan/tests/scaffold_builder.py
+
+[testenv:scaffolds-33]
+basepython = python3.3
+deps = pep8
+ gunicorn
+changedir={[testenv:scaffolds-26]changedir}
+commands=pecan create testing123
+ curl "http://python-distribute.org/distribute_setup.py" -O
+ {envpython} distribute_setup.py
+ {envpython} testing123/setup.py install
+ {envpython} testing123/setup.py test -q
+ pep8 --repeat --show-source testing123/setup.py testing123/testing123
+ {envpython} {toxinidir}/pecan/tests/scaffold_builder.py
+
[testenv:pep8]
deps = pep8
-commands = pep8 --repeat --show-source --exclude *compat*,resources.py pecan setup.py
+commands = pep8 --repeat --show-source pecan setup.py