summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini7
1 files changed, 4 insertions, 3 deletions
diff --git a/tox.ini b/tox.ini
index a9bfc81..593f2ad 100644
--- a/tox.ini
+++ b/tox.ini
@@ -96,10 +96,11 @@ basepython = python2.7
deps = nose
ipaddr
simplegeneric
-changedir = {envdir}/build/wsme
-commands = pip install --build {envdir}/build --pre --no-clean --no-use-wheel wsme
- {envdir}/bin/python setup.py develop
+changedir = {envdir}/src
+commands = pip install --download {envdir}/src --pre --no-deps --no-clean --no-use-wheel wsme
+ sh -c "find -iname 'wsme*.tar.gz' | xargs tar --strip-components 1 -xf"
{envdir}/bin/pip install -U {toxinidir} # install pecan-dev
+ {envdir}/bin/pip install .
nosetests -v tests/pecantest
[testenv:wsme-tip]